1253.Problem A. Alice and Bob

Time Limit: 1000 MS    Memory Limit: 32768 KB
Total Submission(s): 2    Accepted Submission(s): 2

Description

Alice have a friend Bob, they like play games very much, They like to play games is to grab the stone, this classic game they play much times, so today they intend to make the classic reproduction, playing an overnight grab stone,  they are two people who like innovation, so this time they got a new game is played

a. There are N heap stones here.

b. Each time you can select stones that do not exceed M heap for any operation

c.   They play game in turns and cannot do nothing

d.   People who cannot move stones are losers

e.   Alice first

Input

The first line is T(0 < T <= 1000) T is TestCase

Next line is N, M(0 < N, M <= 10000)

Next line follow N number P, P is the number of stones in the stone heap(0 < P <= 10000)

Output

Case #TestCase: winner

If Alice win output Alice, otherwise Bob

Sample Input

15 11 2 3 4 5

Sample Output

Case #1: Alice

             大体意思就是在规定每次可以对任意不大于m堆进行任意操作,以alice先手后~谁能赢的问题。

             下面上ac代码

#include<iostream>
#include<cstdio>
#include<vector>
#include<queue>
#include<functional>
#include<cstring>
using namespace std;
int sum[10005] = { 0 };
int n, m;
int main()
{
	int te;
	cin >> te;
	for (int t = 1; t <= te; t++)
	{
		int n, m;
		cin >> n >> m;
		memset(sum, 0, sizeof(sum));
		if (m != 1)
		{
			int len = 0;
			for (int s = 0; s < n; s++)
			{
				int tem;
				scanf("%d", &tem);
				int tlen = 0;
				while (tem)
				{
					sum[tlen] += tem % 2;
					tem = tem / 2;
					tlen++;
				}
				if (tlen - 1 > len)
				{
					len = tlen - 1;
				}
			}
			int spot = 0;
			for (int s = 0; s <= len; s++)
			{
				sum[s] = sum[s] % (m + 1);
		//		cout << sum[s] << endl;
				if (sum[s] != 0)
				{
					spot = 1;
					break;
				}
			}
			if (spot)
			{
				printf("Case #%d: Alice\n", t);
			}
			else
			{
				printf("Case #%d: Bob\n", t);
			}
		}
		else
		{
			int sum = 0;
			for (int s = 0; s < n;s++)
			{
				int f;
				scanf("%d", &f);
				sum = sum^f;
			}
			if (sum)
			{
				printf("Case #%d: Alice\n", t);
			}
			else
			{
				printf("Case #%d: Bob\n", t);
			}
		}
	}
	return 0;
}