Description:

Keeping track of all the cows can be a tricky task so Farmer John has installed a system to automate it. He has installed on each cow an electronic ID tag that the system will read as the cows pass by a scanner. Each ID tag’s contents are currently a single string with length M (1 ≤ M ≤ 2,000) characters drawn from an alphabet of N (1 ≤ N ≤ 26) different symbols (namely, the lower-case roman alphabet).

Cows, being the mischievous creatures they are, sometimes try to spoof the system by walking backwards. While a cow whose ID is “abcba” would read the same no matter which direction the she walks, a cow with the ID “abcb” can potentially register as two different IDs (“abcb” and “bcba”).

FJ would like to change the cows’s ID tags so they read the same no matter which direction the cow walks by. For example, “abcb” can be changed by adding “a” at the end to form “abcba” so that the ID is palindromic (reads the same forwards and backwards). Some other ways to change the ID to be palindromic are include adding the three letters “bcb” to the begining to yield the ID “bcbabcb” or removing the letter “a” to yield the ID “bcb”. One can add or remove characters at any location in the string yielding a string longer or shorter than the original string.

Unfortunately as the ID tags are electronic, each character insertion or deletion has a cost (0 ≤ cost ≤ 10,000) which varies depending on exactly which character value to be added or deleted. Given the content of a cow’s ID tag and the cost of inserting or deleting each of the alphabet’s characters, find the minimum cost to change the ID tag so it satisfies FJ’s requirements. An empty ID tag is considered to satisfy the requirements of reading the same forward and backward. Only letters with associated costs can be added to a string.

Input:

Line 1: Two space-separated integers: N and M
Line 2: This line contains exactly M characters which constitute the initial ID string
Lines 3…N+2: Each line contains three space-separated entities: a character of the input alphabet and two integers which are respectively the cost of adding and deleting that character.

Output:

Line 1: A single line with a single integer that is the minimum cost to change the given name tag.

Sample Input:

3 4
abcb
a 1000 1100
b 350 700
c 200 800

Sample Output:

900

题目链接

动态规划。d[i][j]表示把字符串str中区间i~j(str[i~j])字符串改变为回文串的最小花费。

若str[i]=str[j]:dp[i][j]=dp[i+1][j-1]。

若str[i]≠str[j]:

  1. 把str[i+1~j]改变为回文串,然后再计算dp[i][j],dp[i][j]=dp[i+1][j]+cost[str[i]]
  2. 把str[i~j-1]改变为回文串,然后再计算dp[i][j],dp[i][j]=dp[i][j-1]+cost[str[j]]

以样例为例:

第一次k循环中先求所有区间长度为1的dp值,str[0~1]=“ab”,所以dp[0][1]就取min(dp[1][1]+cost[str[0]],dp[0][0]+cost[str[1]]),dp[1][1]+cost[str[0]]代表把"b"改变为回文串然后去掉左边的一个a或者在右边添加一个a(所以字母花费取其添加和删除的最小值即可),dp[0][0]+cost[str[1]]代表把"a"改变为回文串然后去掉右边的一个b或者在左边添加一个b,其余同理。

第二次k循环中求所有区间长度为2的dp值,str[0~2]=“abc”,所以dp[0][2]就取min(dp[1][2]+cost[str[0]],dp[0][1]+cost[str[2]]),dp[1][2]+cost[str[0]]代表把"bc"改变为回文串(dp[1][2])然后去掉左边的一个a或者在右边添加一个a,dp[0][1]+cost[str[2]]代表把"ab"改变为回文串(dp[0][1])然后去掉右边的一个c或者在左边添加一个c,其余同理。

第三次k循环中求所有区间长度为3的dp值……

AC代码:

#pragma comment(linker, "/STACK:102400000,102400000")
//#include <bits/stdc++.h>
#include <iostream>
#include <iomanip>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <climits>
#include <stdlib.h>
#include <deque>
#include <queue>
#include <stack>
#include <algorithm>
#include <list>
#include <map>
#include <set>
#include <utility>
#include <sstream>
#include <complex>
#include <string>
#include <vector>
#include <bitset>
#include <complex>
#include <functional>
#include <fstream>
#include <ctime>
#include <stdexcept>
using namespace std;
#define mem(a,b) memset(a,b,sizeof(a))
#define pb push_back
#define mp make_pair
typedef long long ll;
typedef unsigned long long ull;
typedef pair<int,int> P;
const int INF = 0x3f3f3f3f;
const int maxn = 2e3+5;
const int mod = 1e9+7;
const double eps = 1e-8;
const double pi = asin(1.0)*2;
const double e = 2.718281828459;
bool Finish_read;
template<class T>inline void read(T &x){Finish_read=0;x=0;int f=1;char ch=getchar();while(!isdigit(ch)){if(ch=='-')f=-1;if(ch==EOF)return;ch=getchar();}while(isdigit(ch))x=x*10+ch-'0',ch=getchar();x*=f;Finish_read=1;}
inline void fre() {freopen("in.txt", "r", stdin);/*freopen("out.txt", "w", stdout);*/}

int n, m;
string str;
char x;
int add, del;
int dp[maxn][maxn];
map<char, int> r;

inline int min(int a, int b, int c) {
	return min(min(a, b), c);
}

int main() {
// fre();
	read(n); read(m);
	cin >> str;
	for (int i = 1; i <= n; ++i) {
		cin >> x;
		read(add); read(del);
		r[x] = add < del ? add : del;
	}
	mem(dp, 0);
	for (int k = 1; k < m; ++k) {
		for (int i = 0, j = k; j < m; ++i, ++j) {
			dp[i][j] = INF;
			if (str[i] == str[j]) {
				dp[i][j] = dp[i + 1][j - 1];
			}
			else {
				dp[i][j] = min(dp[i + 1][j] + r[str[i]], dp[i][j], dp[i][j - 1] + r[str[j]]);
			}
		}
	}
	printf("%d\n", dp[0][m - 1]);
    return 0;
}