Heavy Transportation

Description

Background
Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant steel crane to the place where it is needed on which all streets can carry the weight.
Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may become. But you surely know.

Problem
You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo's place) to crossing n (the customer's place). You may assume that there is at least one path. All streets can be travelled in both directions.

Input

The first line contains the number of scenarios (city plans). For each city the number n of street crossings (1 <= n <= 1000) and number m of streets are given on the first line. The following m lines contain triples of integers specifying start and end crossing of the street and the maximum allowed weight, which is positive and not larger than 1000000. There will be at most one street between each pair of crossings.

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the maximum allowed weight that Hugo can transport to the customer. Terminate the output for the scenario with a blank line.

Sample Input

1
3 3
1 2 3
1 3 4
2 3 5

Sample Output

Scenario #1:
4

题意描述:

求1到n的所有路径中最小值最大的值;(就是为了能够多拉货物,使所走路径中的最小承受重量的道路值最大)。

解题思路:

迪杰斯特拉变形,dis数组每次查找最大值进行比较,当有道路的最小值都比dis中的值大更新;

最后输出dis[n].

#include<stdio.h>
#include<string.h>
# define inf 99999999
int map[1010][1010],dis[1010],book[1010];
int min(int a,int b)
{
	if(a>b)
		return b;
	else
		return a;
}
int main()
{
	int t,n,m,i,j,u,v,cut,max,a,b,c;
	while(scanf("%d",&t)!=EOF)
	{
		cut=0;
		while(t--)
		{
			cut++;
			scanf("%d%d",&n,&m);
			for(i=1;i<=n;i++)
				for(j=1;j<=n;j++)
				{
						map[i][j]=0;
				}
			for(i=1;i<=m;i++)
			{
				scanf("%d%d%d",&a,&b,&c);
				if(c>map[a][b])
				{
					map[a][b]=c;
					map[b][a]=c;
				}
			}
			memset(book,0,sizeof(book));
			for(i=1;i<=n;i++)
				dis[i]=map[1][i];
			book[1]=1;
			for(i=1;i<n;i++)
			{
				max=-1;
				for(j=1;j<=n;j++)
				{
					if(book[j]==0&&dis[j]>max)
					{
						max=dis[j];
						u=j;
					}
				}
				book[u]=1;
				for(v=1;v<=n;v++)
				{
					if(dis[v]<min(dis[u],map[u][v]))
						dis[v]=min(dis[u],map[u][v]);
				}
			}
			printf("Scenario #%d:\n",cut);
			printf("%d\n\n",dis[n]);
		}
	}
	return 0;
}