题目
计算两个非负整数 <math> <semantics> <mrow> <mi> A </mi> <mo separator="true"> , </mo> <mi> B </mi> </mrow> <annotation encoding="application/x-tex"> A,B </annotation> </semantics> </math>A,B 的乘积, <math> <semantics> <mrow> <mi> A </mi> <mo separator="true"> , </mo> <mi> B </mi> </mrow> <annotation encoding="application/x-tex"> A,B </annotation> </semantics> </math>A,B 可能会很大。
输入格式
第一行输入一个非负整数 <math> <semantics> <mrow> <mi> A </mi> </mrow> <annotation encoding="application/x-tex"> A </annotation> </semantics> </math>A。
第二行输入一个非负整数 <math> <semantics> <mrow> <mi> B </mi> </mrow> <annotation encoding="application/x-tex"> B </annotation> </semantics> </math>B。
<math> <semantics> <mrow> <mi> A </mi> <mo separator="true"> , </mo> <mi> B </mi> </mrow> <annotation encoding="application/x-tex"> A,B </annotation> </semantics> </math>A,B 的长度不大于 <math> <semantics> <mrow> <mn> 500 </mn> </mrow> <annotation encoding="application/x-tex"> 500 </annotation> </semantics> </math>500。
输出格式
输出 <math> <semantics> <mrow> <mi> A </mi> <mo> × </mo> <mi> B </mi> </mrow> <annotation encoding="application/x-tex"> A\times B </annotation> </semantics> </math>A×B 的值。
样例输入
4321
1234
样例输出
5332114
题解
先转置,再运算
#include<iostream>
#include<string>
#include<string.h>
#include<algorithm>
using namespace std;
int main(){
string A,B;
int ReverseA[1000+5];
int ReverseB[1000+5];
int a[1000+5];
memset(a,0,sizeof(a));
cin>>A>>B;
int lenA = A.length();
int lenB = B.length();
// 得到逆转数组
for(int i=0;i<lenA;i++)
ReverseA[i] = A[lenA-i-1]-'0';
for(int i=0;i<lenB;i++)
ReverseB[i] = B[lenB-i-1]-'0';
// 计算
for(int i=0;i<lenA;i++)
for(int j=0;j<lenB;j++){
a[i+j] += ReverseA[i]*ReverseB[j];
// 处理进位
if(a[i+j]>=10){
a[i+j+1] += a[i+j]/10;
a[i+j] %= 10;
}
}
// 控制输出
bool flag = false;
for(int i=lenA+lenB;i>=0;i--){
if(a[i] && !flag || i==0) // 答案为 0 的特殊情况
flag = true;
else if(!a[i] && !flag)
continue;
cout<<a[i];
}
return 0;
}