XHXJ's LIS

Problem Description
#define xhxj (Xin Hang senior sister(学姐))
If you do not know xhxj, then carefully reading the entire description is very important.
As the strongest fighting force in UESTC, xhxj grew up in Jintang, a border town of Chengdu.
Like many god cattles, xhxj has a legendary life:
2010.04, had not yet begun to learn the algorithm, xhxj won the second prize in the university contest. And in this fall, xhxj got one gold medal and one silver medal of regional contest. In the next year's summer, xhxj was invited to Beijing to attend the astar onsite. A few months later, xhxj got two gold medals and was also qualified for world's final. However, xhxj was defeated by zhymaoiing in the competition that determined who would go to the world's final(there is only one team for every university to send to the world's final) .Now, xhxj is much more stronger than ever,and she will go to the dreaming country to compete in TCO final.
As you see, xhxj always keeps a short hair(reasons unknown), so she looks like a boy( I will not tell you she is actually a lovely girl), wearing yellow T-shirt. When she is not talking, her round face feels very lovely, attracting others to touch her face gently。Unlike God Luo's, another UESTC god cattle who has cool and noble charm, xhxj is quite approachable, lively, clever. On the other hand,xhxj is very sensitive to the beautiful properties, "this problem has a very good properties",she always said that after ACing a very hard problem. She often helps in finding solutions, even though she is not good at the problems of that type.
Xhxj loves many games such as,Dota, ocg, mahjong, Starcraft 2, Diablo 3.etc,if you can beat her in any game above, you will get her admire and become a god cattle. She is very concerned with her younger schoolfellows, if she saw someone on a DOTA platform, she would say: "Why do not you go to improve your programming skill". When she receives sincere compliments from others, she would say modestly: "Please don’t flatter at me.(Please don't black)."As she will graduate after no more than one year, xhxj also wants to fall in love. However, the man in her dreams has not yet appeared, so she now prefers girls.
Another hobby of xhxj is yy(speculation) some magical problems to discover the special properties. For example, when she see a number, she would think whether the digits of a number are strictly increasing. If you consider the number as a string and can get a longest strictly increasing subsequence the length of which is equal to k, the power of this number is k.. It is very simple to determine a single number’s power, but is it also easy to solve this problem with the numbers within an interval? xhxj has a little tired,she want a god cattle to help her solve this problem,the problem is: Determine how many numbers have the power value k in [L,R] in O(1)time.
For the first one to solve this problem,xhxj will upgrade 20 favorability rate。
 Input
First a integer T(T<=10000),then T lines follow, every line has three positive integer L,R,K.(
0<L<=R<2 63-1 and 1<=K<=10).
Output
For each query, print "Case #t: ans" in a line, in which t is the number of the test case starting from 1 and ans is the answer.
Sample Input
1 123 321 2
Sample Output
Case #1: 139 求l到r区间内,数字本身的最长上升子序列的长度等于k的数有多少…… 看了题解才做出来的……状压+数位…… 昨天因为有一个longlong弄成了int,wa了一上午……
#include <iostream>
#include <string.h>
#include <stdio.h>
#include <algorithm>
using namespace std;
int k;
long long f[40][1 << 12][12];
int bit[40];
int get(int st)
{
    int cnt = 0;
    while(st)
    {
        if (st & 1) cnt++;
        st >>= 1;
    }
    return cnt;
}

int newst(int x, int st)
{
    for(int i = x; i < 10; i++)
        if(st & (1 << i))return (st ^ (1 << i)) | (1 << x);
    return st | (1 << x);
}
long long dp(int pos, int st, bool flag, bool zero)
{
	if (pos <= 0) return get(st) == k;
	if (flag && f[pos][st][k] != - 1) return f[pos][st][k];
	long long ans = 0;
	int d = flag ? 9 : bit[pos];
	for (int i = 0; i <= d; i++)
	{
		ans += dp(pos - 1, (zero && i == 0 ) ? 0 : newst(i, st), flag || i != d, zero && (i == 0));
	}
	if  (flag) f[pos][st][k] = ans;
	return ans;
}
long long calc(long long x)
{
	int len = 0;
	while (x)
	{
		bit[++len] = x % 10;
		x /= 10;
	}
	return dp(len, 0, 0, 1);
}
int main()
{
	int t;
	long long a, b;
	memset(f, -1, sizeof(f));
	scanf("%d", &t);
	int c = 0;
	while (t--)
	{
		c++;
		scanf("%I64d%I64d%d", &a, &b, &k);;
		printf("Case #%d: ",c);
        printf("%I64d\n",calc(b) - calc(a - 1));
	}
	return 0;
}