问题 E: 费解的开关

时间限制: 1 Sec  内存限制: 128 MB

题目描述

你玩过“拉灯”游戏吗?25盏灯排成一个5x5的方形。每一个灯都有一个开关,游戏者可以改变它的状态。每一步,游戏者可以改变某一个灯的状态。游戏者改变一个灯的状态会产生连锁反应:和这个灯上下左右相邻的灯也要相应地改变其状态。
我们用数字“1”表示一盏开着的灯,用数字“0”表示关着的灯。下面这种状态
10111
01101
10111
10000
11011
在改变了最左上角的灯的状态后将变成:
01111
11101
10111
10000
11011
再改变它正中间的灯后状态将变成:
01111
11001
11001
10100
11011

给定一些游戏的初始状态,编写程序判断游戏者是否可能在6步以内使所有的灯都变亮。

 

输入

第一行有一个正整数n,代表数据***有n个待解决的游戏初始状态。
以下若干行数据分为n组,每组数据有5行,每行5个字符。每组数据描述了一个游戏的初始状态。各组数据间用一个空行分隔。
对于30%的数据,n<=5;
对于100%的数据,n<=500。

 

输出

输出数据一共有n行,每行有一个小于等于6的整数,它表示对于输入数据中对应的游戏状态最少需要几步才能使所有灯变亮。
对于某一个游戏初始状态,若6步以内无法使所有灯变亮,请输出“-1”。 

 

样例输入

复制样例数据

3
00111
01011
10001
11010
11100

11101
11101
11110
11111
11111

01111
11111
11111
11111
11111

样例输出

3
2
-1 

反着考虑,把所有情况都列出来就行了

/**/
#include <cstdio>
#include <cstring>
#include <cmath>
#include <cctype>
#include <iostream>
#include <algorithm>
#include <map>
#include <set>
#include <vector>
#include <string>
#include <stack>
#include <queue>

typedef long long LL;
using namespace std;

int t;
int str;
map<int, int>mp;//你想开数组,呵呵,超空间,这就是预处理的坏处

int solve(int x, int pos){ //牛逼
	x ^= (1 << pos);
	if(pos > 4) x ^= (1 << (pos - 5));
	if(pos < 20) x ^= (1 << (pos + 5));
	if(pos % 5) x ^= (1 << (pos - 1));
	if(pos % 5 < 4) x ^= (1 << (pos + 1));
	return x;
}

void init(){
	str = (1 << 25) - 1;
	queue<int> q;
	q.push(str);
	mp[str] = 0;
	while(q.size()){
		int t = q.front();
		q.pop();
		if(mp[t] == 6) return ;
		for (int i = 0; i < 25; i++){
			int x = solve(t, i);
			if(!mp[x]){
				mp[x] = mp[t] + 1;
				q.push(x);
			}
		}
	}
}

int main()
{
	//freopen("in.txt", "r", stdin);
	//freopen("out.txt", "w", stdout);

	scanf("%d", &t);
	init();
	while(t--){
		int x = 0;
		char s[6][6];
		for (int i = 1; i <= 5; i++) scanf("%s", s[i] + 1);
		for (int i = 1; i <= 5; i++){
			for (int j = 1; j <= 5; j++){
				x <<= 1;
				x += s[i][j] - '0';
			}
		}
		if(x == ((1 << 25) - 1)){
			printf("0\n");
		}else if(mp[x]){
			printf("%d\n", mp[x]);
		}else{
			printf("-1\n");
		}
		
	}

	return 0;
}
/**/