4 Values whose Sum is 0

Time Limit: 15000MS Memory Limit: 228000K
Case Time Limit: 5000MS

Description

The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how many quadruplet (a, b, c, d ) ∈ A x B x C x D are such that a + b + c + d = 0 . In the following, we assume that all lists have the same size n .

Input

The first line of the input file contains the size of the lists n (this value can be as large as 4000). We then have n lines containing four integer values (with absolute value as large as 228 ) that belong respectively to A, B, C and D .

Output

For each input file, your program has to write the number quadruplets whose sum is zero.

Sample Input

6
-45 22 42 -16
-41 -27 56 30
-36 53 -37 77
-36 30 -75 -46
26 -38 -10 62
-32 -54 -6 45
Sample Output

5

Hint

Sample Explanation: Indeed, the sum of the five following quadruplets is zero: (-45, -27, 42, 30), (26, 30, -10, -46), (-32, 22, 56, -46),(-32, 30, -75, 77), (-32, -54, 56, 30).

思路:

如果用暴力解决的话,需要n4的时间复杂度,所以暴力肯定是不行的,所以这里要用折半枚举的方法,也就是先用a,b数组将a,b相加的情况枚举出来,因为a + b + c + d = 0所以有a + b = - c - d因此,再用枚举好的和后面的c,d进行判断,再用一个二分来解决。

#include <iostream>
#include <algorithm>
using namespace std;
const int maxn = 4010;
int a[maxn], b[maxn], c[maxn], d[maxn], ab[maxn * maxn];
int main() {
	int n;
	scanf("%d", &n);
	for (int i = 0; i < n; i++) {
		scanf("%d %d %d %d", &a[i], &b[i], &c[i], &d[i]);
	}
	int cnt = 0;
	for (int i = 0; i < n; i++) {
		for (int j = 0; j < n; j++) {
			ab[cnt++] = a[i] + b[j];
		}
	}
	sort(ab, ab + cnt);
	int ans = 0;
	for (int i = 0; i < n; i++) {
		for (int j = 0; j < n; j++) {
			int x = -(c[i] + d[j]);
			ans += upper_bound(ab, ab + cnt, x) - lower_bound(ab, ab + cnt, x);
		}
	}
	cout << ans << endl;
	return 0;
}