数据结构上机测试2-1:单链表操作A

Problem Description

输入n个整数,先按照数据输入的顺序建立一个带头结点的单链表,再输入一个数据m,将单链表中的值为m的结点全部删除。分别输出建立的初始单链表和完成删除后的单链表。
Input

第一行输入数据个数n;
第二行依次输入n个整数;
第三行输入欲删除数据m。
Output

第一行输出原始单链表的长度;
第二行依次输出原始单链表的数据;
第三行输出完成删除后的单链表长度;
第四行依次输出完成删除后的单链表数据。
Example Input

10
56 25 12 33 66 54 7 12 33 12
12
Example Output

10
56 25 12 33 66 54 7 12 33 12
7
56 25 33 66 54 7 33
```

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
struct node
{
    int data;
    struct node *next;
}*head,*tail,*p,*q;
struct node *Delete(struct node * head,int n,int m)//这个当时我是用C写的,所以用delete写没有关键字冲突,如果用c++的话应该避免这个关键字改个名
{
    struct node* p,*q;
    p=head;
    q=p->next;
    while(p)
    {
        if(q->data==m)
        {
            n--;
            p->next=q->next;
            p=q;
            free(q);
            q=p->next;
        }
        else {
                p=p->next;
                q=q->next;
             }
    }
    return (head);
}
int main()
{
    int n;
    scanf("%d",&n);
    head=(struct node*)malloc(sizeof(struct node));
    head->next=NULL;
    tail=head;
    int i;
    for(i=1;i<=n;i++)
    {
        p=(struct node*)malloc(sizeof(struct node));
        scanf("%d",&p->data);
        p->next=NULL;
        tail->next=p;
        tail=p;
    }
    int m;
    scanf("%d",&m);
    printf("%d\n",n);
    p=head->next;
    while(p)
    {
        printf("%d ",p->data);
        p=p->next;
    }
    printf("\n");
    Delete(head,n,m);
    p=head->next;
    printf("%d\n",n);
    while(p)
    {
        printf("%d ",p->data);
        p=p->next;
    }
    return 0;
}
```