题目链接:http://nyoj.top/problem/309

  • 内存限制:64MB 时间限制:1000ms

题目描述

Dr.Kong has entered a bobsled competition because he hopes his hefty weight will give his an advantage over the L meter course (2 <= L<= 1000). Dr.Kong will push off the starting line at 1 meter per second, but his speed can change while he rides along the course. Near the middle of every meter Bessie travels, he can change his speed either by using gravity to accelerate by one meter per second or by braking to stay at the same speed or decrease his speed by one meter per second.

Naturally, Dr.Kong must negotiate N (1 <= N <= 500) turns on the way down the hill. Turn i is located T_i  meters from the course start (1 <= T_i <= L-1), and  he must be enter the corner meter at  a peed of at most S_i  meters per second (1 <= S_i <= 1000).  Dr.Kong can cross the finish line at any speed he likes.

Help Dr.Kong learn the fastest speed he can attain without exceeding the speed limits on the turns.

Consider this course with the meter markers as integers and the  turn speed limits in brackets (e.g., '[3]'):

 0    1   2   3   4   5   6   7[3]   8   9  10  11[1]  12   13[8]    14                    

(Start) |------------------------------------------------------------------------| (Finish)

Below is a chart of  Dr.Kong 's speeds at the beginning of each meter length of the course:

Max:                               [3]             [1]      [8]

Mtrs:   0   1   2   3   4   5   6   7   8   9  10  11  12   13   14 

Spd:    1   2   3   4   5   5   4   3   4   3   2   1   2   3    4

His maximum speed was 5 near the beginning of meter 4.

输入描述

There are multi test cases,your program should be terminated by EOF
Line 1: Two space-separated integers: L and N
Lines 2..N+1:  Line i+1 describes turn i with two space-separated  integers: T_i and S_i

输出描述

Line 1:   A single integer,  representing the maximum speed which  Dr.Kong can attain between the start and the finish line,  inclusive.

样例输入

14 3
7 3
11 1
13 8

样例输出

5

解题思路

从起点滑到终点,中间有一些转弯,转弯时有速度限制,而且在滑行过程中没一米只能匀加速或者匀减速,当转弯时需要提前开始减速,才能顺利通过。所以当遇到转弯,速度过大时,就需要更新前面的数据,才能符合条件。
v[i]表示在第i米时可以滑行的最大速度,然后假设一直加速,从前往后遍历每个区间,当到某个拐角时的速度大于这个拐角的最大速度时,就向前更新前面的点的最大速度。

#include <bits/stdc++.h>
using namespace std;
int main() {
    int l, n, a, b, v[1005];
    while (~scanf("%d%d", &l, &n)) {
        memset(v, 0, sizeof(v));
        for (int i = 0; i < n; i++) {
            scanf("%d%d", &a, &b);
            v[a] = b;
        }
        v[0] = 1;
        for (int i = 1; i <= l; i++) {
            if (!v[i])//不是拐弯的地方一直加速 
                v[i] = v[i - 1] + 1;
            else {
                if (v[i] > v[i - 1])//拐弯地方 
                    v[i] = v[i - 1] + 1;
                else {//如果到达拐弯处速度过大,就要更新前面的 
                    int x = i;//从第i个开始更新 
                    while (v[x - 1] > v[x] + 1) {//一直更新到符合条件 
                        v[x - 1] = v[x] + 1;
                        x--;
                    }
                }
            }
        }
        int max_ = 0;
        for (int i = 0; i <= l; i++) {
            if (max_ < v[i])//寻找最大速度 
                max_ = v[i];
        }
        printf("%d\n", max_);
    }
    return 0;
}