题目链接:传送门

Problem Description

There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected. 

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.

Input

The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.

Output

You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum. 

Sample Input

3
0 990 692
990 0 179
692 179 0
1
1 2

Sample Output

179

题目大意:有n个城市,给出一个n*n矩阵,矩阵中第i行第j个数表示城市i与j间的距离。再给出Q,有Q行数据表示x城市与y城市间已经有道路,求出,畅通所有城市需要建设的道路的最小长度。

Kruskal算法:

#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
struct node
{
    int x,y,t;
}n[100500];//这里数组要开大,不然报运行超时,虽然不知道为啥
int m[1005];
int s,w;
bool cmp(node a,node b)
{
    return a.t<b.t;
}
int fin(int a)
{
    while(m[a]!=a)
        a=m[a];
    return a;
}
int main()
{
    int a,b,c,d,e,f,i,j;
    while(~scanf("%d",&s))
    {
        e=0;
    for(a=0;a<s;a++)
    {
        for(b=0;b<s;b++)
        {
            scanf("%d",&c);
            if(a>b)
            {
                n[e].x=a+1;
                n[e].y=b+1;
                n[e].t=c;
                e++;
            }
        }
    }
    sort(n,n+e,cmp);
    for(a=0;a<=s;a++)
        m[a]=a;
    scanf("%d",&f);
    while(f--)
    {
        scanf("%d %d",&b,&c);
        i=fin(b);
        j=fin(c);
        m[i]=j;
    }
    w=0;
    for(a=0;a<e;a++)
    {
        i=fin(n[a].x);
        j=fin(n[a].y);
        if(i!=j)
        {
            w+=n[a].t;
            m[i]=j;
        }
    }
    printf("%d\n",w);
    }
    return 0;
}