题干:

  Long long ago, in the Kingdom Far Far Away, there lived many little animals. And you are the beloved princess who is marrying the prince of a rich neighboring kingdom. The prince, who turns out to be a handsome guy, offered you a golden engagement ring that can run computer programs! 
  The wedding will be held next summer because your father, the king, wants you to finish your university first. 
  But you did’t even have a clue on your graduation project. Your terrible project was to construct a map for your kingdom. Your mother, the queen, wanted to make sure that you could graduate in time. 
  Or your wedding would have to be delayed to the next winter. So she told you how your ancestors built the kingdom which is called the Roads Principle: 

  1. Your kingdom consists of N castles and M directed roads. 
  2. There is at most one road between a pair of castles. 
  3. There won’t be any roads that start at one castle and lead to the same one. 
  She hoped those may be helpful to your project. Then you asked your cousin Coach Pang (Yes, he is your troubling cousin, he always asks you to solve all kinds of problems even you are a princess.), the Minister of Traffic, about the castles and roads. Your cousin, sadly, doesn’t have a map of the kingdom. Though he said the technology isn’t well developed and it depends on your generation to contribute to the map, he told you the Travelers Guide, the way travelers describe the amazing road system: 
  1. No matter which castle you start with, you can arrive at any other castles. 
  2. Traveling on theM roads will take 1, 2, 3, ... ,M days respectively, no two roads need the same number of days. 
  3. You can take a round trip starting at any castle, visiting a sequence of castles, perhaps visiting some castles or traveling on some roads more than once, and finish your journey where you started.
  4. The total amount of days spent on any round trip will be a multiple of three. 
  But after a month, you still couldn’t make any progress. So your brother, the future king, asked your university to assign you a simpler project. And here comes the new requirements. Construct a map that satisfies both the Roads Principle and the Travelers Guide when N and M is given. 
  There would probably be several solutions, but your project would be accepted as long as it meets the two requirements. 
Now the task is much easier, furthermore your fiance sent two assistants to help you. 
  Perhaps they could finish it within 5 hours and you can think of your sweet wedding now.

Input

  The first line contains only one integer T, which indicates the number of test cases. 
  For each test case, there is one line containing two integers N, M described above.(10 <= N <= 80, N+3 <= M <= N 2/7 )

Output

  For each test case, first output a line “Case #x:”, where x is the case number (starting from 1). 
  Then output M lines for each test case. Each line contains three integers A, B, C separated by single space, which denotes a road from castle A to castle B and the road takes C days traveling. 
  Oh, one more thing about your project, remember to tell your mighty assistants that if they are certain that no map meets the requirements, print one line containing one integer -1 instead. 
  Note that you should not print any trailing spaces.

Sample Input

1
6 8

Sample Output

Case #1:
1 2 1
2 3 2
2 4 3
3 4 4
4 5 5
5 6 7
5 1 6
6 1 8  

Hint

The restrictions like N >= 10 will be too big for a sample. So the sample is just a simple case for the detailed formats of input and output,
 and it may be helpful for a better understanding. Anyway it won’t appear in actual test cases.

题目大意:

现在给你n个点 m条边,你要构造出来一个有向图,有向图的边权各不相同,从1到m 。并且要求从一个点到其他所有点都是联通的,还要求从一个点出发,回到该点走的路径权值一定要是3的倍数,并且任意两点之间最多只能有一条边,

解题报告:

因为题目保证有解,所以直接连接所有顶点成环,成链的边的权值直接就是1~n-1就行,因为n号点到1号点的边一定可以通过其他权值构造出来,因为这题保证了N+3 <= M。构造一个环了之后看还剩下多少权值,在模3相等的点上直接加边就行了。

AC代码:

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<queue>
#include<map>
#include<vector>
#include<set>
#include<string>
#include<cmath>
#include<cstring>
#define F first
#define S second
#define ll long long
#define pb push_back
#define pm make_pair
using namespace std;
typedef pair<int,int> PII;
const int MAX = 2e4 + 5;
bool ok[MAX];
int sum[MAX];
int n,m,top[MAX],qq[3][MAX];
int main()
{
	int t,iCase=0;
	cin>>t;
	while(t--) {
		scanf("%d%d",&n,&m);
		memset(sum,0,sizeof sum);
		printf("Case #%d:\n",++iCase);
		for(int i = 1; i<=n-1; i++) {
			printf("%d %d %d\n",i,i+1,i);
			sum[i+1] = sum[i] + i;
		}
		top[0]=top[1]=top[2]=0;
		for(int val = n; val<=m; val++) qq[val%3][++top[val%3]] = val;
		int x = (30000000 + (sum[1]-sum[n])%3)%3;
		printf("%d 1 %d\n",n,qq[x][top[x]--]);
		for(int i = 1; i<=n-2; i++) {
			for(int j = i+2; j<=n; j++) {
				if(i!=1 || j!=n) {
					int x = (30000000 + sum[j] - sum[i])%3;
					if(top[x]) printf("%d %d %d\n",i,j,qq[x][top[x]--]);
				}
			}
		}
	}
	return 0 ;
}
/*
1
4 7

*/

 

总结:

注意前缀和算的时候不能这样写:

for(int i = 1; i<n-1; i++) {
			printf("%d %d %d\n",i,i+1,i);
			sum[i] = sum[i-1] + i;
			ok[i]=1;
			sum += i;
		}

另一点:这两句是等价的。当不好估计上界的时候就可以下面这样写。

int x = (30000000 + (sum[1]-sum[n])%3)%3;
int x = (3+(sum[1]-sum[n])%3)%3;