零起点学算法22——华氏摄氏温度转换

Time Limit: 1 Sec  Memory Limit: 64 MB   64bit IO Format: %lld
 


Description

输入一个华氏温度,根据公式C=(5/9)(F-32)计算对应的摄氏温度。 

 

Input

输入一个华氏温度值(多组数据)

 

Output

输出输入的华氏温度和转换后的摄氏温度值。

输入格式请参考样例(每组数据一行)

 

Sample Input

100

 

Sample Output

fahr=100.000000,celsius=37.777779

 

HINT

 

计算中所有数据使用 float 类型  注意 float 常量的写法


题目分析:注意用公式就行,还有要用float,double会错。


#include<stdio.h>
int main(){
    float c,f;
	while(scanf("%f",&f)!=EOF)
	{
		c=5*(f-32)/9;
		printf("fahr=%.6f,celsius=%.6f\n",f,c);
	}
    return 0;
}