Description

FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.

 

Input

The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.

 

Output

For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.

 

Sample Input

5 3

7 2

4 3

5 2

20 3

25 18

24 15

15 10

-1 -1

Sample Output

13.333

31.500

题意:

     有m的猫粮,n个房间,每个房间有一定量的javabean,在房间获取百分之多少的javabean,就要付出相应比例的猫粮,求m磅的猫粮最多可以获得多少javabean。

思路:

     把每个房间可以获得的javabean和付出的猫粮比率存在一个数组,排序。从比率最大的房间开始,一直到没有猫粮了。

代码:

#include<stdio.h>
int main()
{
	int n,m,i,j;
	double sum,t;
	double r[1010];
	int je[1010],f[1010];
	while(scanf("%d%d",&m,&n)!=EOF)
	{
		if(m==-1&&n==-1)
			break;
		sum=0;
		for(i=1;i<=n;i++)
		{
			scanf("%d%d",&je[i],&f[i]);
			r[i]=je[i]*1.0/f[i];
		}
		for(i=1;i<n;i++)
			for(j=i+1;j<=n;j++)
			{
				if(r[i]<r[j])
				{
					t=r[i];
					r[i]=r[j];
					r[j]=t;
					t=je[i];
					je[i]=je[j];
					je[j]=t;
					t=f[i];
					f[i]=f[j];
					f[j]=t;
				}
			}
		for(i=1;i<=n;i++)
		{
			if(m>f[i])
			{
				m-=f[i];
				sum+=je[i];
			}
			else
			{
				sum+=r[i]*m;
				break;
			}
		}
		printf("%.3f\n",sum);
	}
	return 0;
}