题目链接:http://poj.org/problem?id=1287
Time Limit: 1000MS Memory Limit: 10000K

Description

You are assigned to design network connections between certain points in a wide area. You are given a set of points in the area, and a set of possible routes for the cables that may connect pairs of points. For each possible route between two points, you are given the length of the cable that is needed to connect the points over that route. Note that there may exist many possible routes between two given points. It is assumed that the given possible routes connect (directly or indirectly) each two points in the area. 
Your task is to design the network for the area, so that there is a connection (direct or indirect) between every two points (i.e., all the points are interconnected, but not necessarily by a direct cable), and that the total length of the used cable is minimal.

Input

The input file consists of a number of data sets. Each data set defines one required network. The first line of the set contains two integers: the first defines the number P of the given points, and the second the number R of given routes between the points. The following R lines define the given routes between the points, each giving three integer numbers: the first two numbers identify the points, and the third gives the length of the route. The numbers are separated with white spaces. A data set giving only one number P=0 denotes the end of the input. The data sets are separated with an empty line. 
The maximal number of points is 50. The maximal length of a given route is 100. The number of possible routes is unlimited. The nodes are identified with integers between 1 and P (inclusive). The routes between two points i and j may be given as i j or as j i. 

Output

For each data set, print one number on a separate line that gives the total length of the cable used for the entire designed network.

Sample Input

1 0

2 3
1 2 37
2 1 17
1 2 68

3 7
1 2 19
2 3 11
3 1 7
1 3 5
2 3 89
3 1 91
1 2 32

5 7
1 2 5
2 3 7
2 4 8
4 5 11
3 5 10
1 5 6
4 2 12

0

Sample Output

0
17
16
26

Problem solving report:

Description: 该区域设计网络,以便在每两个点之间存在连接(直接或间接连接),并且总长度最小。
Problem solving: 最小生成树板子题。

Accepted Code:

/* 
 * @Author: lzyws739307453 
 * @Language: C++ 
 */
#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
using namespace std;
const int MAXN = 55;
const int MAXM = 55 * 55;
const int inf = 0x3f3f3f3f;
struct edge {
    int u, v, w;
    bool operator < (const edge &s) const {
        return s.w > w;
    }
}e[MAXM];
int n, m, f[MAXN];
bool cmp(edge a, edge b) {
    return a.w < b.w;
}
int getf(int v) {
    if (f[v] != v)
        return f[v] = getf(f[v]);
    return v;
}
bool merge(int u, int v, int w) {
    int t1 = getf(u);
    int t2 = getf(v);
    if (t1 != t2) {
        f[t2] = t1;
        return true;
    }
    return false;
}
int Kruskal() {
    int cnt = 0, count_ = 0;
    for (int i = 1; i <= n; i++)
        f[i] = i;
    sort(e, e + m);
    for (int i = 0; i < m && count_ < n - 1; i++) {
        if (merge(e[i].u, e[i].v, e[i].w)) {
            cnt += e[i].w;
            count_++;
        }
    }
    return cnt;
}
int main() {
    while (scanf("%d", &n), n) {
        scanf("%d", &m);
        for (int i = 0; i < m; i++)
            scanf("%d%d%d", &e[i].u, &e[i].v, &e[i].w);
        printf("%d\n", Kruskal());
    }
    return 0;
}