Bad Cowtractors

Time Limit: 1000MS Memory Limit: 65536K

Description

Bessie has been hired to build a cheap internet network among Farmer John’s N (2 <= N <= 1,000) barns that are conveniently numbered 1…N. FJ has already done some surveying, and found M (1 <= M <= 20,000) possible connection routes between pairs of barns. Each possible connection route has an associated cost C (1 <= C <= 100,000). Farmer John wants to spend the least amount on connecting the network; he doesn’t even want to pay Bessie.

Realizing Farmer John will not pay her, Bessie decides to do the worst job possible. She must decide on a set of connections to install so that (i) the total cost of these connections is as large as possible, (ii) all the barns are connected together (so that it is possible to reach any barn from any other barn via a path of installed connections), and (iii) so that there are no cycles among the connections (which Farmer John would easily be able to detect). Conditions (ii) and (iii) ensure that the final set of connections will look like a “tree”.

Input

  • Line 1: Two space-separated integers: N and M

  • Lines 2…M+1: Each line contains three space-separated integers A, B, and C that describe a connection route between barns A and B of cost C.

Output

  • Line 1: A single integer, containing the price of the most expensive tree connecting all the barns. If it is not possible to connect all the barns, output -1.

Sample Input

5 8
1 2 3
1 3 7
2 3 10
2 4 4
2 5 8
3 4 6
3 5 2
4 5 17

Sample Output

42

Hint

OUTPUT DETAILS:

The most expensive tree has cost 17 + 8 + 10 + 7 = 42. It uses the following connections: 4 to 5, 2 to 5, 2 to 3, and 1 to 3.

思路:

套用下最小生成树kruscal的模板就行了,然后就是在判断-1的之前加一个计数的cnt用来记录有多少个点合并了,如果都合并了就输出答案,否则输出-1.

#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;
const int maxn = 1010;
const int maxm = 20010;
struct Edge {
    int u;
    int v;
    int dis;
    bool friend operator < (Edge a, Edge b) {
        return a.dis > b.dis;
    }
};
Edge edge[maxm];
int father[maxn];
int FindFather(int x) {
    int a = x;
    while (father[x] != x) x = father[x];
    while (a != father[a]) {
        int z = a;
        a = father[a];
        father[z] = x;
    }
    return x;
}
void UnionFather(int a, int b) {
    int fa = FindFather(a);
    int fb = FindFather(b);
    if (fa != fb) father[fa] = fb;
}
int main() {
    ios::sync_with_stdio(false);
    int n, m;
    scanf("%d %d", &n, &m);
    for (int i = 1; i <= n; i++) father[i] = i;
    for (int i = 0; i < m; i++) {
        scanf("%d %d %d", &edge[i].u, &edge[i].v, &edge[i].dis);
    }
    int ans = 0, cnt = 0;
    sort(edge, edge + m);
    for (int i = 0; i < m; i++) {
        if (FindFather(edge[i].u) != FindFather(edge[i].v)) {
            UnionFather(edge[i].u, edge[i].v);
            ans += edge[i].dis;
            cnt++;
            if (cnt == n - 1) break;
        }
    }
    if (cnt != n - 1) printf("-1\n");
    else printf("%d\n", ans);
    return 0;
}