Robotic Sort

Time Limit: 6000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3741    Accepted Submission(s): 1629


Problem Description
Somewhere deep in the Czech Technical University buildings, there are laboratories for examining mechanical and electrical properties of various materials. In one of yesterday’s presentations, you have seen how was one of the laboratories changed into a new multimedia lab. But there are still others, serving to their original purposes.

In this task, you are to write software for a robot that handles samples in such a laboratory. Imagine there are material samples lined up on a running belt. The samples have different heights, which may cause troubles to the next processing unit. To eliminate such troubles, we need to sort the samples by their height into the ascending order.

Reordering is done by a mechanical robot arm, which is able to pick up any number of consecutive samples and turn them round, such that their mutual order is reversed. In other words, one robot operation can reverse the order of samples on positions between A and B.

A possible way to sort the samples is to find the position of the smallest one (P1) and reverse the order between positions 1 and P1, which causes the smallest sample to become first. Then we find the second one on position P and reverse the order between 2 and P2. Then the third sample is located etc.



The picture shows a simple example of 6 samples. The smallest one is on the 4th position, therefore, the robot arm reverses the first 4 samples. The second smallest sample is the last one, so the next robot operation will reverse the order of five samples on positions 2–6. The third step will be to reverse the samples 3–4, etc.

Your task is to find the correct sequence of reversal operations that will sort the samples using the above algorithm. If there are more samples with the same height, their mutual order must be preserved: the one that was given first in the initial order must be placed before the others in the final order too.
 

Input
The input consists of several scenarios. Each scenario is described by two lines. The first line contains one integer number N , the number of samples, 1 ≤ N ≤ 100 000. The second line lists exactly N space-separated positive integers, they specify the heights of individual samples and their initial order.

The last scenario is followed by a line containing zero.
 

Output
For each scenario, output one line with exactly N integers P1 , P1 , . . . PN ,separated by a space.
Each Pi must be an integer (1 ≤ Pi ≤ N ) giving the position of the i-th sample just before the i-th reversal operation.

Note that if a sample is already on its correct position Pi , you should output the number Pi anyway, indicating that the “interval between Pi and Pi ” (a single sample) should be reversed.
 

Sample Input
6 3 4 5 1 6 2 4 3 3 2 1 0
 

Sample Output
4 6 4 5 6 6 4 2 4 4

【题意】

       给了N个数的一个序列,现在要把这n个数变成完全从小到大排列的N个数,那么如何变呢?每次在当前位置找后面所有的最小的数的位置,然后把当前位置和找到的这个位置的这个区间的数反转过来。最后要输出每个数在第i次操作之前的第i个数的位置。

【解题方法】

        Splay做法比较显然。对区间有反转,同样用懒惰标记,SPT比较方便。依次考虑第K大的,将其旋转至根,左子树的数量便是需要反转的,之后把根删除即可。但是考虑到这道题没有区间询问的话,那么久没有必要建两个虚拟根节点出来了,也可以减少一些代码。

【参考BLOG&&学习途径】爱神

【AC 代码】

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
const int inf=0x3f3f3f3f;
const int maxn=100005;
#define Key_value ch[ch[root][1]][0];
int pre[maxn],key[maxn],ch[maxn][2],root,tot1;
int size[maxn];
int rev[maxn];//反转标记
int n,q;
inline void newnode(int &r,int father,int k)
{
    r=k;
    pre[r]=father;
    rev[r]=0;
    size[r]=1;
    ch[r][0]=ch[r][1]=0;
}
inline void pushdown(int r)
{
    if(rev[r])
    {
        rev[ch[r][0]]^=1;
        rev[ch[r][1]]^=1;
        swap(ch[r][0],ch[r][1]);
        rev[r]=0;
    }
}
inline void pushup(int r)
{
    size[r]=size[ch[r][0]]+size[ch[r][1]]+1;
}
void Rotate(int x,int kind)
{
    int y=pre[x];
    pushdown(y);
    pushdown(x);
    ch[y][!kind]=ch[x][kind];
    pre[ch[x][kind]]=y;
    pre[x]=pre[y];
    if(pre[x]) ch[pre[y]][ch[pre[y]][1]==y]=x;
    ch[x][kind]=y;
    pre[y]=x;
    pushup(y);
}
void Splay(int r,int goal)
{
    pushdown(r);
    while(pre[r]!=goal)
    {
        if(pre[pre[r]]==goal)
        {
            pushdown(pre[r]);
            pushdown(r);
            Rotate(r,ch[pre[r]][0]==r);
        }
        else
        {
            pushdown(pre[pre[r]]);
            pushdown(pre[r]);
            pushdown(r);
            int y=pre[r];
            int kind=(ch[pre[y]][0]==y);
            if(ch[y][kind]==r){
                Rotate(r,!kind);
                Rotate(r,kind);
            }
            else
            {
                Rotate(y,kind);
                Rotate(r,kind);
            }
        }
    }
    pushup(r);
    if(goal==0) root=r;
}
int Get_Max(int r)
{
    pushdown(r);
    while(ch[r][1])
    {
        r=ch[r][1];
        pushdown(r);
    }
    return r;
}
void Remove()//删除根节点
{
    if(ch[root][0]==0)
    {
        root=ch[root][1];
        pre[root]=0;
    }
    else
    {
        int m=Get_Max(ch[root][0]);
        Splay(m,root);
        ch[m][1]=ch[root][1];
        pre[ch[root][1]]=m;
        root=m;
        pre[root]=0;
        pushup(root);
    }
}
void BuildTree(int &x,int l,int r,int father)
{
    if(l>r) return ;
    int mid=(l+r)/2;
    newnode(x,father,mid);
    BuildTree(ch[x][0],l,mid-1,x);
    BuildTree(ch[x][1],mid+1,r,x);
    pushup(x);
}
struct node{
    int id,num;
    bool operator<(const node &rhs) const
    {
        if(num!=rhs.num) return num<rhs.num;
        else return id<rhs.id;
    }
}a[maxn];
void init()
{
    for(int i=1; i<=n; i++)
    {
        scanf("%d",&a[i].num);
        a[i].id=i;
    }
    sort(a+1,a+n+1);
    ch[0][0]=ch[0][1]=pre[0]=size[0]=rev[0]=0;
    root=tot1=0;
    BuildTree(root,1,n,0);
}
int main()
{
    while(scanf("%d",&n)!=EOF&&n)
    {
        init();
        for(int i=1; i<n; i++)
        {
            Splay(a[i].id,0);
            rev[ch[root][0]]^=1;
            printf("%d ",i+size[ch[root][0]]);
            Remove();
        }
        printf("%d\n",n);
    }
    return 0;
}