UVa 679 Dropping Balls

题目:

A number of K balls are dropped one by one from the root of a fully binary tree structure FBT. Each
time the ball being dropped first visits a non-terminal node. It then keeps moving down, either follows
the path of the left subtree, or follows the path of the right subtree, until it stops at one of the leaf
nodes of FBT. To determine a ball’s moving direction a flag is set up in every non-terminal node with
two values, either false or true. Initially, all of the flags are false. When visiting a non-terminal node
if the flag’s current value at this node is false, then the ball will first switch this flag’s value, i.e., from
the false to the true, and then follow the left subtree of this node to keep moving down. Otherwise,
it will also switch this flag’s value, i.e., from the true to the false, but will follow the right subtree of
this node to keep moving down. Furthermore, all nodes of FBT are sequentially numbered, starting at
1 with nodes on depth 1, and then those on depth 2, and so on. Nodes on any depth are numbered
from left to right.
For example, Fig. 1 represents a fully binary tree of maximum depth 4 with the node numbers 1,
2, 3, …, 15. Since all of the flags are initially set to be false, the first ball being dropped will switch
flag’s values at node 1, node 2, and node 4 before it finally stops at position 8. The second ball being
dropped will switch flag’s values at node 1, node 3, and node 6, and stop at position 12. Obviously,
the third ball being dropped will switch flag’s values at node 1, node 2, and node 5 before it stops at
position 10.

Fig. 1: An example of FBT with the maximum depth 4 and sequential node numbers.

Now consider a number of test cases where two values will be given for each test. The first value is
D, the maximum depth of FBT, and the second one is I, the I-th ball being dropped. You may assume
the value of I will not exceed the total number of leaf nodes for the given FBT.
Please write a program to determine the stop position P for each test case.
For each test cases the range of two parameters D and I is as below:
2 ≤ D ≤ 20, and 1 ≤ I ≤ 524288.

Input
Contains l + 2 lines.
Line 1 l the number of test cases
Line 2 D1 I1 test case #1, two decimal numbers that are separated by one blank

Line k + 1 Dk Ik test case #k
Line l + 1 Dl Il test case #l
Line l + 2 -1 a constant ‘-1’ representing the end of the input file
Output
Contains l lines.
Line 1 the stop position P for the test case #1

Line k the stop position P for the test case #k

Line l the stop position P for the test case #l
Sample Input
5
4 2
3 4
10 1
2 2
8 128
-1
Sample Output
12
7
512
3
255

题目的意思大概是:给出树的最大深度D小球个数 I ,在根节点放小球下落,小球在经过一个结点时,这个节点的开关状态会改变,开关关闭小球往左走,否则往右走,直到走到叶子节点。
问:最后一个小球走到的叶子节点所在的编号是?

因为小球肯定会走到叶子节点,只需要知道小球编号的奇偶性就可以知道它在根节点时落在哪颗子树上。这是一个递归的过程,依次类推直到叶子节点。

  1. 当小球编号I是奇数时,它是往左走的第(I+1)/2个小球;
  2. 当小球编号I是偶数时,它是往右走的第 I/2 个小球;

由此可得:

#include <iostream>

using namespace std;

int main()
{
    int D = 0, I = 0, n = 0;
    while (cin >> n  && (n != -1)) {
        for (int i = 0; i < n; i++) {
            cin >> D >> I;
            int res = 1;
            for (int j = 0; j < D - 1; j++) {//模拟计算小球将到达的每一个节点的位置
                if (I % 2) {//如果是奇数则往左结点走
                    res *= 2;//下一个左结点的下标
                    I = (I + 1) / 2;//走这个结点的小球编号
                }
                else {//走右结点
                    res = res * 2 + 1;//下一个右结点下标
                    I /= 2; //走这个结点的小球编号
                }
            }
            cout << res << endl;//模拟完毕后得到最终的叶子结点下标
        }
    }
    return 0;
}