题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2955
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Problem Description

The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university.


For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.

His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.

Input

The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj . 
Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .

Output

For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.

Notes and Constraints
0 < T <= 100
0.0 <= P <= 1.0
0 < N <= 100
0 < Mj <= 100
0.0 <= Pj <= 1.0
A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.

Sample Input

3
0.04 3
1 0.02
2 0.03
3 0.05
0.06 3
2 0.03
2 0.03
3 0.05
0.10 3
1 0.03
2 0.02
3 0.05

Sample Output

2
4
6

Problem solving report:

Description: 给一个最大风险值,有很多银行,Mj表示第j个银行有多少钱,Pj表示抢这个银行的风险值,求在给定最大风险值的范围内最多能抢到的金额。
Problem solving: 01背包问题,但需要将能抢来的最多的钱最为背包容量,转换成求抢劫一定金额时最大的逃跑的概率!此题目的核心和关键就是进行转化。

#include <bits/stdc++.h>
using namespace std;
int v[105], n, ans;
double w[105], dp[10005], p;
int main() {
    int t;
    scanf("%d", &t);
    while (t--) {
        ans = 0;
        memset(dp, 0, sizeof(dp));
        scanf("%lf%d", &p, &n);
        for (int i = 0; i < n; i++) {
            scanf("%d%lf", &v[i], &w[i]);
            w[i] = 1 - w[i];
            ans += v[i];
        }
        p = 1 - p;
        dp[0] = 1;
        for (int i = 0; i < n; i++) {
            for (int j = ans; j >= v[i]; j--)
                dp[j] = max(dp[j], dp[j - v[i]] * w[i]);
        }
        for (int i = ans; i >= 0; i--) {
            if (dp[i] >= p) {
                printf("%d\n", i);
                break;
            }
        }
    }
    return 0;
}