Here is a simple game. In this game, there are several piles of matches and two players. The two player play in turn. In each turn, one can choose a pile and take away arbitrary number of matches from the pile (Of course the number of matches, which is taken away, cannot be zero and cannot be larger than the number of matches in the chosen pile). If after a player’s turn, there is no match left, the player is the winner. Suppose that the two players are all very clear. Your job is to tell whether the player who plays first can win the game or not.

Input

The input consists of several lines, and in each line there is a test case. At the beginning of a line, there is an integer M (1 <= M <=20), which is the number of piles. Then comes M positive integers, which are not larger than 10000000. These M integers represent the number of matches in each pile.

Output

For each test case, output "Yes" in a single line, if the player who play first will win, otherwise output "No".

Sample Input

2 45 45
3 3 6 9

Sample Output

No
Yes

题意:

      有任意堆的火柴,两个选手依次拿走火柴,每次可以从一堆中拿走大于0的任意数量的火柴,拿走火柴后没有剩余,则这个选手获胜。

思路:

      按位异或如果结果为0,先手必输,否则先手必赢。

      45 ^ 45 = 0,所以先手必输;

      3 ^ 6  ^ 9 不为0,所以先手必赢。

代码:

#include<stdio.h>
int main()
{
	int a[22];
	int m,n,i;
	while(~scanf("%d",&m))
	{
		for(i=1;i<=m;i++)
			scanf("%d",&a[i]);
		n = a[1];
		for(i=2;i<=m;i++)
		{
			n^=a[i];
		}
		if(n!=0)
			printf("Yes\n");
		else
			printf("No\n");
	}
	return 0;
 }