描述

Give you a convex(凸边形), diagonal n-3 disjoint divided into n-2 triangles(直线), for different number of methods, such as n=5, there are 5 kinds of partition method, as shown in Figure

输入

The first line of the input is a n (1<=n<=1000), expressed n data set. 
The next n lines each behavior an integer m (3<=m<=18), namely the convex edges.

输出

For each give m,, output how many classification methods. 
example output: Case #a : b

样例输入




5

样例输出

Case #1 : 1 
Case #2 : 2 
Case #3 : 5

题目大意:

输入一个数n,接下来有n组测试数据,接下来的n行每一个行为都是整数m(3 < = m=18),求m边形分成m-2个三角形的不同分法有几种。

c++

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int main()
{
    int a[20];
    int t,T=1,n,i,j,b;
    a[2]=a[3]=1;
    for(i=3;i<20;i++)
    {
        a[i]=0;
        b=i-1;
        for(j=2;j<i;j++)
        {
            a[i]+=a[j]*a[b];
            b--;
        }
    }
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        printf("Case #%d : %d\n",T++,a[n]);
    }
    return 0;
}