1030 Travel Plan (30 point(s))

A traveler’s map gives the distances between cities along the highways, together with the cost of each highway. Now you are supposed to write a program to help a traveler to decide the shortest path between his/her starting city and the destination. If such a shortest path is not unique, you are supposed to output the one with the minimum cost, which is guaranteed to be unique.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 4 positive integers N, M, S, and D, where N (≤500) is the number of cities (and hence the cities are numbered from 0 to N−1); M is the number of highways; S and D are the starting and the destination cities, respectively. Then M lines follow, each provides the information of a highway, in the format:

City1 City2 Distance Cost
where the numbers are all integers no more than 500, and are separated by a space.

Output Specification:

For each test case, print in one line the cities along the shortest path from the starting point to the destination, followed by the total distance and the total cost of the path. The numbers must be separated by a space and there must be no extra space at the end of output.

Sample Input:

4 5 0 3
0 1 1 20
1 3 2 30
0 3 4 10
0 2 2 20
2 3 1 20

Sample Output:

0 2 3 3 40

思路:

就是Dijsktra算法的模板题。先套用模板,然后求出带有路径的数组pre,然后递归输出路径,然后最短路和最小花费在模板里不断更新,

#include <iostream>
#include <algorithm>
#include <cstdio>
using namespace std;
const int inf = 0x7fffffff;
const int maxn = 510;
int pre[maxn], cost[maxn][maxn], map[maxn][maxn], d[maxn], c[maxn];
bool book[maxn] = {false};
int n, m, ed, st;
void Dijsktra(int s) {
    fill(d, d + n, inf);
    fill(c, c + n, inf);
    for (int i = 0; i < n; i++) pre[i] = i;
    d[s] = c[s] = 0;
    for (int i = 0; i < n; i++) {
        int u = -1, minn = inf;
        for (int j = 0; j < n; j++) {
            if (book[j] == false && minn > d[j]) {
                u = j;
                minn = d[j];
            }
        }
        if (u == -1) return ;
        book[u] = true;
        for (int v = 0; v < n; v++) {
            if (book[v] == false && map[u][v] != inf) {
                if (d[u] + map[u][v] < d[v]) {
                    d[v] = d[u] + map[u][v];
                    c[v] = c[u] + cost[u][v];
                    pre[v] = u;
                } else if (d[u] + map[u][v] == d[v]) {
                    if (c[u] + cost[u][v] < c[v]) {
                        c[v] = c[u] + cost[u][v];
                        pre[v] = u;
                    }
                }
            }
        }
    }
}
void dfs(int v) {
    if (v == st) {
        printf("%d ", v);
        return ;
    }
    dfs(pre[v]);
    printf("%d ", v);
    return ;
}
int main() {
    scanf("%d %d %d %d", &n, &m, &st, &ed);
    for (int i = 0; i < n; i++) fill(map[i], map[i] + n, inf);
    for (int i = 0; i < n; i++) fill(cost[i], cost[i] + n, inf);
    for (int i = 0; i < m; i++) {
        int a, b, c, d;
        scanf("%d %d %d %d", &a, &b, &c, &d);
        map[a][b] = map[b][a] = c;
        cost[a][b] = cost[b][a] = d;
    }
    Dijsktra(st);
    dfs(ed);
    printf("%d %d", d[ed], c[ed]);
    return 0;
}