Problem Description
Ms.Fang loves painting very much. She paints GFW(Great Funny Wall) every day. Every day before painting, she produces a wonderful color of pigments by mixing water and some bags of pigments. On the K-th day, she will select K specific bags of pigments and mix them to get a color of pigments which she will use that day. When she mixes a bag of pigments with color A and a bag of pigments with color B, she will get pigments with color A xor B.
When she mixes two bags of pigments with the same color, she will get color zero for some strange reasons. Now, her husband Mr.Fang has no idea about which K bags of pigments Ms.Fang will select on the K-th day. He wonders the sum of the colors Ms.Fang will get with different plans.

For example, assume n = 3, K = 2 and three bags of pigments with color 2, 1, 2. She can get color 3, 3, 0 with 3 different plans. In this instance, the answer Mr.Fang wants to get on the second day is 3 + 3 + 0 = 6.
Mr.Fang is so busy that he doesn’t want to spend too much time on it. Can you help him?
You should tell Mr.Fang the answer from the first day to the n-th day.

Input
There are several test cases, please process till EOF.
For each test case, the first line contains a single integer N(1 <= N <= 103).The second line contains N integers. The i-th integer represents the color of the pigments in the i-th bag.

Output
For each test case, output N integers in a line representing the answers(mod 106 +3) from the first day to the n-th day.

Sample Input
4
1 2 10 1

Sample Output
14 36 30 8

  • 思路
    显然暴力的枚举每一种情况必定会超时的,考虑优化,我们应该注意到答案是任意k个数的异或和相加,由于包含了每一种情况,我们可以对每一二进制位来计算,我们又知道对第i位来说,k个数的xor的值可能为2i-1或0,显然0对答案没有贡献,我们只需求出2i-1的数量即可。
  • 代码
#include<bits/stdc++.h>
#define ll long long
#define mod 1000003
using namespace std;
const double pi=acos(-1);
const int N=1005;
int n;
int num[35];
ll C[N][N],ans[N];
void Initial()//递推组合数
{
    int i,j;
    for(i=0; i<N; ++i)
    {
        C[0][i] = 0;
        C[i][0] = 1;
    }
    for(i=1; i<N; ++i)
    {
        for(j=1; j<N; ++j)
       C[i][j] = (C[i-1][j] + C[i-1][j-1])%mod;
    }
}
int main()
{
	Initial();
    while(scanf("%d",&n)!=-1)
    {
    	memset(num,0,sizeof(num));
    	memset(ans,0,sizeof(ans));
    	int maxx=0;//最大的位数
    	for(int i=1;i<=n;i++)
	    {
	    	ll x;
	    	int cnt=1;
		    scanf("%lld",&x);
		    while(x)
			{
				if(x&1) num[cnt]++;
				x=x>>1;
				cnt++;
			}
			maxx=max(maxx,cnt);
	    }
	    for(int i=1;i<=n;i++)
		{
			for(int j=1;j<maxx;j++)
			{
				ll val=(1<<(j-1));
				for(int k=1;k<=num[j]&&i>=k;k+=2)//枚举奇数,只有奇数个1才使xor对答案有用
				{
					ans[i]=(ans[i]+C[num[j]][k]*C[n-num[j]][i-k]%mod*val%mod)%mod;
				}
			}
		}
		 for(int i=1;i<n;i++)
    		 printf("%lld ",ans[i]);
    		 printf("%lld\n",ans[n]);
    }
    return 0;
}