1032 Sharing (25分)

To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, loading and being are stored as showed in Figure 1.

fig.jpg

Figure 1

You are supposed to find the starting position of the common suffix (e.g. the position of i in Figure 1).

Input Specification:

Each input file contains one test case. For each case, the first line contains two addresses of nodes and a positive N (≤), where the two addresses are the addresses of the first nodes of the two words, and N is the total number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by −.

Then N lines follow, each describes a node in the format:

Address Data Next
	

whereAddress is the position of the node, Data is the letter contained by this node which is an English letter chosen from { a-z, A-Z }, and Next is the position of the next node.

Output Specification:

For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output -1 instead.

Sample Input 1:

11111 22222 9
67890 i 00002
00010 a 12345
00003 g -1
12345 D 67890
00002 n 00003
22222 B 23456
11111 L 00001
23456 e 67890
00001 o 00010
	

Sample Output 1:

67890
	

Sample Input 2:

00001 00002 4
00001 a 10001
10001 s -1
00002 a 10002
10002 t -1
	

Sample Output 2:

-1
具体意思其实就是求两链表的公共结点的开始,建议用静态链表,比较简单,先创建结构体保存节点信息,节点信息中自己添加一个标志位,一开始全部置false,然后输入节点信息,然后从链表一开始从头遍历,链表一的节点flag全部置true,再从链表二开始遍历,一旦遍历到有节点的flag=true,break,输出
小二上代码!
#include<cstdio>
#include<cstring>
const int maxn = 100010;
struct node
{
	char a;
	int next;
	bool flag;
}buf[maxn];
int main()
{
	int s1, s2, n;
	while (scanf("%d%d%d", &s1, &s2, &n) != EOF)
	{
		for (int i = 0; i < n; i++)
			buf[i].flag = false;
		int adr,next;
        char a;
		for (int i = 0; i < n; i++)
		{
			scanf("%d %c %d", &adr,&a,&next);
			buf[adr].a = a;
            buf[adr].next= next;
			
		}
		int p = s1;
		for(p=s1;p!=-1;p= buf[p].next)//遍历,p=-1时结束遍历
			buf[p].flag =true;
		for (p = s2;p != -1; p = buf[p].next)
		{
			if (buf[p].flag == true)
				break;
		}
		if(p!=-1)
			printf("%05d\n", p);
		else
			printf("-1\n");
	}
	return 0;
}