相信大家都听说一个“百岛湖”的地方吧,百岛湖的居民生活在不同的小岛中,当他们想去其他的小岛时都要通过划小船来实现。现在政府决定大力发展百岛湖,发展首先要解决的问题当然是交通问题,政府决定实现百岛湖的全畅通!经过考察小组RPRush对百岛湖的情况充分了解后,决定在符合条件的小岛间建上桥,所谓符合条件,就是2个小岛之间的距离不能小于10米,也不能大于1000米。当然,为了节省资金,只要求实现任意2个小岛之间有路通即可。其中桥的价格为 100元/米。

INPUT

输入包括多组数据。输入首先包括一个整数T(T <= 200),代表有T组数据。
每组数据首先是一个整数C(C <= 100),代表小岛的个数,接下来是C组坐标,代表每个小岛的坐标,这些坐标都是 0 <= x, y <= 1000的整数。

OUTPUT

每组输入数据输出一行,代表建桥的最小花费,结果保留一位小数。如果无法实现工程以达到全部畅通,输出”oh!”.

Sample Input

2
2
10 10
20 20
3
1 1
2 2
1000 1000

Sample Output

1414.2
oh!

一道最小生成树的基础题,直接预处理一下即可,放进符合条件的边到优先队列里面,后面就是基础的直接模板了。

#include<bits/stdc++.h>
using namespace std;
int t,n,flag,f[110],cnt;
double res;
double x[110],y[110];
struct node
{
	int st,end;
	double w;
};
bool operator<(const node &s1,const node &s2)
{
	return s1.w>s2.w;
}
priority_queue<node> pq;
void init()
{
	res=flag=cnt=0;
	for(int i=1;i<=n;i++)	f[i]=i;
	while(!pq.empty())	pq.pop();
}
double dist(int i,int j)
{
	return sqrt((x[j]-x[i])*(x[j]-x[i])+(y[j]-y[i])*(y[j]-y[i]));
}
int find_root(int x)
{
	return x==f[x]?x:f[x]=find_root(f[x]);
}
void union_set(int a,int b)
{
	f[find_root(a)]=find_root(b);
}
int main()
{
	cin>>t;
	while(t--)
	{
		cin>>n;
		init();
		for(int i=1;i<=n;i++)	cin>>x[i]>>y[i];
		for(int i=1;i<=n;i++)
		{
			for(int j=i+1;j<=n;j++)
			{
				if(dist(i,j)-10>=0&&1000-dist(i,j)>=0)	pq.push({i,j,dist(i,j)});
			}
		}
		while(!pq.empty()&&cnt<n-1)
		{
			int fa=find_root(pq.top().st);
			int fb=find_root(pq.top().end);
			if(fa!=fb)
			{
				cnt++;
				res+=pq.top().w;
				union_set(pq.top().st,pq.top().end);
			}
			pq.pop();
		}
		if(cnt==n-1)	printf("%.1lf\n",res*100);
		else	cout<<"oh!"<<endl;
	}
	return 0;
}