Navigation Nightmare

Time Limit: 2000MS Memory Limit: 30000K
Total Submissions: 8486 Accepted: 3053
Case Time Limit: 1000MS
Description

Farmer John’s pastoral neighborhood has N farms (2 <= N <= 40,000), usually numbered/labeled 1…N. A series of M (1 <= M < 40,000) vertical and horizontal roads each of varying lengths (1 <= length <= 1000) connect the farms. A map of these farms might look something like the illustration below in which farms are labeled F1…F7 for clarity and lengths between connected farms are shown as (n):
F1 — (13) ---- F6 — (9) ----- F3

        |                                 |

       (3)                                |

        |                                (7)

       F4 --- (20) -------- F2            |

        |                                 |

       (2)                               F5

        | 

       F7 

Being an ASCII diagram, it is not precisely to scale, of course.

Each farm can connect directly to at most four other farms via roads that lead exactly north, south, east, and/or west. Moreover, farms are only located at the endpoints of roads, and some farm can be found at every endpoint of every road. No two roads cross, and precisely one path
(sequence of roads) links every pair of farms.

FJ lost his paper copy of the farm map and he wants to reconstruct it from backup information on his computer. This data contains lines like the following, one for every road:

There is a road of length 10 running north from Farm #23 to Farm #17
There is a road of length 7 running east from Farm #1 to Farm #17

As FJ is retrieving this data, he is occasionally interrupted by questions such as the following that he receives from his navigationally-challenged neighbor, farmer Bob:

What is the Manhattan distance between farms #1 and #23?

FJ answers Bob, when he can (sometimes he doesn’t yet have enough data yet). In the example above, the answer would be 17, since Bob wants to know the “Manhattan” distance between the pair of farms.
The Manhattan distance between two points (x1,y1) and (x2,y2) is just |x1-x2| + |y1-y2| (which is the distance a taxicab in a large city must travel over city streets in a perfect grid to connect two x,y points).

When Bob asks about a particular pair of farms, FJ might not yet have enough information to deduce the distance between them; in this case, FJ apologizes profusely and replies with “-1”.
Input

  • Line 1: Two space-separated integers: N and M

  • Lines 2…M+1: Each line contains four space-separated entities, F1,

      F2, L, and D that describe a road. F1 and F2 are numbers of
    
      two farms connected by a road, L is its length, and D is a
    
      character that is either 'N', 'E', 'S', or 'W' giving the
    
      direction of the road from F1 to F2.
    
  • Line M+2: A single integer, K (1 <= K <= 10,000), the number of FB’s

      queries
    
  • Lines M+3…M+K+2: Each line corresponds to a query from Farmer Bob

      and contains three space-separated integers: F1, F2, and I. F1
    
      and F2 are numbers of the two farms in the query and I is the
    
      index (1 <= I <= M) in the data after which Bob asks the
    
      query. Data index 1 is on line 2 of the input data, and so on.
    

Output

  • Lines 1…K: One integer per line, the response to each of Bob’s

      queries.  Each line should contain either a distance
    
      measurement or -1, if it is impossible to determine the
    
      appropriate distance.
    

Sample Input

7 6
1 6 13 E
6 3 9 E
3 5 7 S
4 1 3 N
2 4 20 W
4 7 2 S
3
1 6 1
1 4 3
2 6 6
Sample Output

13
-1
10
Hint

At time 1, FJ knows the distance between 1 and 6 is 13.
At time 3, the distance between 1 and 4 is still unknown.
At the end, location 6 is 3 units west and 7 north of 2, so the distance is 10.

题目大意:给出n个农场,并且给出m条边,有k个询问,询问x到y的距离是多少,距离计算公式abs(x1-x2)+abs(y1-y2).
思路:
https://blog.csdn.net/blessLZH0108/article/details/60963572
看的这个大佬的题解
然后做了一天终于ac掉了,妈d太恐怖了,大致思路:
先把所有的边的关系和询问离线处理,然后o(m)扫一遍m条边,不离线肯定会超时的,最难的就是用并查集去维护x和y轴,这个我是真的没想到。。。。维护叶子节点与根节点的x,y轴之间的关系,然后路径压缩就也是对x,y轴路径求和,然后根据四个方向确定x,y轴坐标,N S 只需要维护y轴坐标,W E只需维护x轴坐标,然后再对询问的第三个参数做处理,先升序询问,这里需要一个index找回对应边。
并查集果然还是比较难。。。。。。
ac代码:

#include<iostream>
#include<algorithm>
using namespace std;

const int maxn=40010;
const int maxv=10010;
struct node{//存边
	int u,v,w;
	char d;
}a[maxn];
struct edge{//存询问
	int from,to,time,index;
}b[maxv];
struct fa{//并查集
	int F,x,y;
}f[maxn];
struct an{//答案
	int ans,id;
}c[maxv];
int n,m,k,ans;
bool cmp(edge a,edge b){
	return a.time<b.time;
}
int find(int x){
	if(x!=f[x].F){
		int t=f[x].F;
		f[x].F=find(f[x].F);
		f[x].x+=f[t].x;
		f[x].y+=f[t].y;
	}
	return f[x].F;
}
void ufs(int u,int v,int length,char s)
{
    int fx=find(u),fy=find(v);
    if(fx!=fy)
    {
        f[fx].F=fy;
        if(s=='N')
            f[fx].y=f[v].y+length-f[u].y,f[fx].x=f[v].x-f[u].x;
        else if(s=='S')
            f[fx].y=f[v].y-length-f[u].y,f[fx].x=f[v].x-f[u].x;
        else if(s=='E')
            f[fx].x=f[v].x+length-f[u].x,f[fx].y=f[v].y-f[u].y;
        else
            f[fx].x=f[v].x-length-f[u].x,f[fx].y=f[v].y-f[u].y;
    }
}
bool cmp1(an a,an b){
	return a.id<b.id;
}
int main(){
	scanf("%d%d",&n,&m);
	for(int i=1;i<=n;i++){
		f[i].F=i;f[i].x=0;f[i].y=0;
	}
	for(int i=1;i<=m;i++){
		scanf("%d%d%d %c",&a[i].u,&a[i].v,&a[i].w,&a[i].d);
	}
	scanf("%d",&k);
	for(int i=1;i<=k;i++){
		scanf("%d%d%d",&b[i].from,&b[i].to,&b[i].time);
		b[i].index=i;
	}
	int j=1;
	sort(b+1,b+1+k,cmp);
	for(int i=1;i<=k;i++){
		for(;j<=b[i].time;j++){
			ufs(a[j].u,a[j].v,a[j].w,a[j].d);
		}
		int x=b[i].from;int y=b[i].to;
		int fx=find(x);
		int fy=find(y);
		if(fx!=fy){
			ans=-1;
		}else{
			ans=abs(f[y].x-f[x].x)+abs(f[y].y-f[x].y);
		}
		c[i].ans=ans;c[i].id=b[i].index;
	}
	sort(c+1,c+1+k,cmp1); 
	for(int i=1;i<=k;i++){
		printf("%d\n",c[i].ans);
	}
	return 0;
}