Dividing

Description

Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value. Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.

Input

Each line in the input file describes one collection of marbles to be divided. The lines contain six non-negative integers n1 , . . . , n6 , where ni is the number of marbles of value i. So, the example from above would be described by the input-line "1 0 1 2 0 0". The maximum total number of marbles will be 20000. 
The last line of the input file will be "0 0 0 0 0 0"; do not process this line.

Output

For each collection, output "Collection #k:", where k is the number of the test case, and then either "Can be divided." or "Can't be divided.". 
Output a blank line after each test case.

Sample Input

1 0 1 2 0 0 
1 0 0 0 1 1 
0 0 0 0 0 0 

Sample Output

Collection #1:
Can't be divided.

Collection #2:
Can be divided.
  
问均分大理石的方式是否存在
复习背包问题啦!!这是一个多重背包,是采用了二进制思想将第i种物品拆成1,2,4,……,2^(k-1),wi-2^k+1个(k是使wi-2^k+1大于零的最大整数)(这样是可以组成任意小于等于wi的整数的)
   
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const long M = 120010;
bool f[M];
long a[10];
long v;
void ComletePack(long c)
{
    for (long i = c; i <= v; i++)
    {
        if (f[i - c]) f[i] = true;
    }
}
void ZeroOnePack( long c)
{
    for (long i = v; i >= c; i--)
    {
        if (f[i - c]) f[i] = true;
    }
}
void MultiplePack(long c, long m)
{
    if (c * m >= v)
    {
        ComletePack(c);
        return ;
    }
    long k = 1;
    while (k < m)
    {
        ZeroOnePack(k * c);
        m = m - k;
        k = 2 * k;
    }
    ZeroOnePack(m * c);
}
bool dp (long v)
{
    if (v % 2 != 0) return false;
    v = v / 2;
    memset(f, 0, sizeof(f));
    f[0] = true;
    for(long i = 1; i <= 6; i++)
    {
        if(a[i]>0)
        {
            MultiplePack(i, a[i]);
            if (f[v]) return true;
        }
    }
    return false;
}
int main()
{
    v = 0;
    for (long i = 1; i <= 6; i++)
    {
        scanf("%d", &a[i]);
        v += i * a[i];
    }
    long k = 0;
    while (v)
    {
        if (dp(v)) printf("Collection #%d:\nCan be divided.\n\n", ++k);
            else printf("Collection #%d:\nCan't be divided.\n\n", ++k);
        v = 0;
        for (long i = 1; i <= 6; i++)
        {
            scanf("%d", &a[i]);
            v += i * a[i];
        }

    }
    return 0 ;
}