Skiing

Description

Bessie and the rest of Farmer John's cows are taking a trip this winter to go skiing. One day Bessie finds herself at the top left corner of an R (1 <= R <= 100) by C (1 <= C <= 100) grid of elevations E (-25 <= E <= 25). In order to join FJ and the other cows at a discow party, she must get down to the bottom right corner as quickly as she can by travelling only north, south, east, and west.

Bessie starts out travelling at a initial speed V (1 <= V <= 1,000,000). She has discovered a remarkable relationship between her speed and her elevation change. When Bessie moves from a location of height A to an adjacent location of eight B, her speed is multiplied by the number 2^(A-B). The time it takes Bessie to travel from a location to an adjacent location is the reciprocal of her speed when she is at the first location.

Find the both smallest amount of time it will take Bessie to join her cow friends.

Input

* Line 1: Three space-separated integers: V, R, and C, which respectively represent Bessie's initial velocity and the number of rows and columns in the grid.

* Lines 2..R+1: C integers representing the elevation E of the corresponding location on the grid.

Output

A single number value, printed to two exactly decimal places: the minimum amount of time that Bessie can take to reach the bottom right corner of the grid.

Sample Input

1 3 3
1 5 3
6 3 5
2 4 3

Sample Output

29.00

Hint

Bessie's best route is:
Start at 1,1 time 0 speed 1
East to 1,2 time 1 speed 1/16
South to 2,2 time 17 speed 1/4
South to 3,2 time 21 speed 1/8
East to 3,3 time 29 speed 1/4

题意描述:
初始速度为v,在一个n*m的矩阵中给出了各个点的高度,从A到B的速度为A的速度*2^(hA-hB),到B的时间为A点速度的倒数。求从(1,1)点到(n,m)点的最小时间。

解题思路:

看了题解知道了a到c的速度为va*2^(a-b)*2^(b-c)=va*2^(a-c);所以可以求出各个点的速度;在用spfa的bfs算法求出到(n,m)的最小时间。还有就是这道题的无穷大inf不能定义为八个9要2147483647 不然会答案错误。

spfa算法中队首取消标记的作用:

SPFA中一个点可能在出队列之后再次被放入队列,也就是一个点改进过其它的点之后,过了一段时间可能本身被改进(重新入队),于是再次用来改进其它的点,这样反复迭代下去。

关于spfa算法:https://blog.csdn.net/xunalove/article/details/70045815

                         http://lib.csdn.net/article/datastructure/10344

#include<stdio.h>
#include<string.h>
#include<math.h>
# define inf 2147483647
int e[1010][1010],book[1010][1010];
double dis[1010][1010],map[1010][1010];//dis数组存储到各个点的时间,map数组存储各个点的速度 
int next[4][2]={0,1,
				1,0,
				0,-1,
				-1,0};
struct A
{
	int x;
	int y;
}q[10000010],t,f;
int main()
{
	int n,m,i,j,head,tail,k;
	double w,v;
	while(scanf("%lf%d%d",&v,&n,&m)!=EOF)
	{
		for(i=1;i<=n;i++)
			for(j=1;j<=m;j++)
				scanf("%d",&e[i][j]);
		for(i=1;i<=n;i++)
			for(j=1;j<=m;j++)
			{
				map[i][j]=(double)(v*(double)pow(2,1.0*(e[1][1]-e[i][j])));
			}
		map[1][1]=v;//存入各个点速度 
		memset(book,0,sizeof(book));
		for(i=1;i<=n;i++)
			for(j=1;j<=m;j++)
				dis[i][j]=inf;
		dis[1][1]=0;//初始化各个点的时间 
		book[1][1]=1;
		head=0;
		tail=1;
		t.x=1;
		t.y=1;
		q[head]=t;
		while(head<tail)
		{
			t=q[head];
			head++;
			book[t.x][t.y]=0;//队首取消标记 
			for(k=0;k<=3;k++)
			{
				f.x=t.x+next[k][0];
				f.y=t.y+next[k][1];
				w=1.0/map[t.x][t.y];
				if(f.x>=1&&f.x<=n&&f.y>=1&&f.y<=m&&dis[f.x][f.y]>dis[t.x][t.y]+w)
				{
					dis[f.x][f.y]=dis[t.x][t.y]+w;//符合条件更新dis数组为最小 
					if(book[f.x][f.y]==0)
					{
						q[tail]=f;
						tail++;
						book[f.x][f.y]=1;
					}
				 } 
			}
		}
		printf("%.2f\n",dis[n][m]);
	}
	return 0;
}