C Looooops

Time Limit: 1000MS Memory Limit: 65536K

Description

A Compiler Mystery: We are given a C-language style for loop of type
for (variable = A; variable != B; variable += C)

statement;

I.e., a loop which starts by setting variable to value A and while variable is not equal to B, repeats statement followed by increasing the variable by C. We want to know how many times does the statement get executed for particular values of A, B and C, assuming that all arithmetics is calculated in a k-bit unsigned integer type (with values 0 <= x < 2k) modulo 2k.

Input

The input consists of several instances. Each instance is described by a single line with four integers A, B, C, k separated by a single space. The integer k (1 <= k <= 32) is the number of bits of the control variable of the loop and A, B, C (0 <= A, B, C < 2k) are the parameters of the loop.

The input is finished by a line containing four zeros.

Output

The output consists of several lines corresponding to the instances on the input. The i-th line contains either the number of executions of the statement in the i-th instance (a single integer number) or the word FOREVER if the loop does not terminate.
Sample Input

3 3 2 16
3 7 2 16
7 3 2 16
3 4 2 16
0 0 0 0

Sample Output

0
2
32766
FOREVER

题意:

问什么A加上C取模2k等于B,其中经历了几次循环,还是永远无法使等式成立。

思路:

有题意知(A + x * C) mod 2 k = B mod 2 k可以推导出x * C + y * 2 k = B - A所以就有 a = C, b = 2 k, c = B - A, 然后就是扩展欧几里得得模板了,不会的可以先看看这题得解析这题poj1061,这两题比较类似。还有记住要用longlong还有就是在计算2k时一般就是用1 << k,这样的话在1得时候记得将类型强制转换。

#include <iostream>
#include <cstdio>
using namespace std;
typedef long long ll;
ll Exgcd(ll a, ll b, ll &x, ll &y) {
    if (b == 0) {
        x = 1;
        y = 0;
        return a;
    }
    ll g = Exgcd(b, a % b, x, y);
    ll t = x;
    x = y;
    y = t - a / b * y;
    return g;
}
int main() {
    ll a, b, c, k;
    while (scanf("%lld %lld %lld %lld", &a, &b, &c, &k)!= EOF && a + b + c + k) {
        ll x, y, aa = c, bb = (1ll << k), cc = b - a;
        ll gcd = Exgcd(aa, bb, x, y);
        if (cc % gcd != 0) printf("FOREVER\n");
        else {
            x *= cc / gcd;
            ll t = bb / gcd;
            x = (x % t + t) % t;
            printf("%lld\n", x);
        }
    }
    return 0;
}