Cow Bowling

Time Limit: 1000MS Memory Limit: 65536K

Description

The cows don’t use actual bowling balls when they go bowling. They each take a number (in the range 0…99), though, and line up in a standard bowling-pin-like triangle like this:

          7



        3   8



      8   1   0



    2   7   4   4



  4   5   2   6   5

Then the other cows traverse the triangle starting from its tip and moving “down” to one of the two diagonally adjacent cows until the “bottom” row is reached. The cow’s score is the sum of the numbers of the cows visited along the way. The cow with the highest score wins that frame.

Given a triangle with N (1 <= N <= 350) rows, determine the highest possible sum achievable.

Input

Line 1: A single integer, N

Lines 2…N+1: Line i+1 contains i space-separated integers that represent row i of the triangle.

Output

Line 1: The largest sum achievable using the traversal rules
Sample Input

5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

Sample Output

30

Hint

Explanation of the sample:

          7

         *

        3   8

       *

      8   1   0

       *

    2   7   4   4

       *
  4   5   2   6   5

路径 7-3-8-7-5

The highest score is achievable by traversing the cows as shown above.

思路:

简单的动态规划,创建一个新数组记录到改点的最大的数值,该数值会等于上方能走的路径的最大值加上该点的权值,最后在这些点中,最大的数值就是要求的值了。

#include <iostream>
using namespace std;
int dp[500][500] = {0};
int a[500][500] = {0};
int main() {
	int n, maxn = 0;
	cin >> n;
	for (int i = 1; i <= n; i++) {
		for (int j = 1; j <= i; j++) {
			cin >> a[i][j];
			dp[i][j] = max(dp[i - 1][j] + a[i][j], dp[i - 1][j - 1] + a[i][j]);
			maxn = max(dp[i][j], maxn);
		}
	} 
	cout << maxn << endl;
	return 0;
}