描述

编写一个程序实现将字符串中的所有"you"替换成"we"

<dl class="others"> <dt> 输入 </dt> <dd> 输入包含多行数据  

每行数据是一个字符串,长度不超过1000 
数据以EOF结束
</dd> <dt> 输出 </dt> <dd> 对于输入的每一行,输出替换后的字符串 </dd> <dt> 样例输入 </dt> <dd>
you are what you do
</dd> <dt> 样例输出 </dt> <dt>     we are what we do </dt> <dt> STL string 练手题: </dt> <dt> 熟悉 find 函数,以及 replace 函数 </dt> </dl>
//Asimple
#include <iostream>
#include <string>

using namespace std;
string str, s1="you", s2="we";

int main()
{
    int pos;
    while( getline(cin,str) )
    {
        pos = str.find(s1,0);
        while( pos != string::npos )
        {
            str.replace(pos,3,s2);
            pos = str.find(s1,pos+1);
        }
        cout << str << endl ;
    }
    return 0;
}