Coprime Sequence
Do you know what is called ``Coprime Sequence’’? That is a sequence consists of nn positive integers, and the GCD (Greatest Common Divisor) of them is equal to 1.

Coprime Sequence’’ is easy to find because of its restriction. But we can try to maximize the GCD of these integers by removing exactly one integer. Now given a sequence, please maximize the GCD of its elements.

Input
The first line of the input contains an integer T(1≤T≤10)T(1≤T≤10), denoting the number of test cases.

In each test case, there is an integer n(3≤n≤100000)n(3≤n≤100000) in the first line, denoting the number of integers in the sequence.

Then the following line consists of nn integers a1,a2,…,an(1≤ai≤109)a1,a2,…,an(1≤ai≤109), denoting the elements in the sequence.

Output
For each test case, print a single line containing a single integer, denoting the maximum GCD.

Sample Input
3
3
1 1 1
5
2 2 2 3 2
4
1 2 4 8

Sample Output
1
2
2

以前做过一个求序列中去除一个数的最大或和的题,比赛的时候就没想起来用前缀和后缀!!!
扇自己两巴掌

#include <bits/stdc++.h>
using namespace std;
const int N=1e5+5;
int a[N],b[N],c[N];
int gcd(int a,int b)
{
   
    return b==0?a:gcd(b,a%b);
}
int main()
{
   
    int t,n,m,i;
    scanf("%d",&t);
    while(t--)
    {
   
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
        memset(c,0,sizeof(c));
        scanf("%d",&n);
        for(i=0;i<n;i++)
        {
   
            scanf("%d",&a[i]);
            if(i)
                b[i]=gcd(b[i-1],a[i]);
            if(!i)
                b[i]=a[i];
        }
        c[n-1]=a[n-1];
        for(i=n-2;i>=0;i--)
        {
   
            c[i]=gcd(c[i+1],a[i]);
        }
        int maxx=max(b[n-2],c[1]);
        for(i=1;i<n-1;i++)
        {
   
            maxx=max(maxx,gcd(b[i-1],c[i+1]));
        }
        cout<<maxx<<'\n';
    }
    return 0;
}