本题的基本要求非常简单:给定N个实数,计算它们的平均值。但复杂的是有些输入数据可能是非法的。一个“合法”的输入是[-1000,1000]区间内的实数,并且最多精确到小数点后2位。当你计算平均值的时候,不能把那些非法的数据算在内。

输入格式:

输入第一行给出正整数N(<=100)。随后一行给出N个正整数,数字间以一个空格分隔。

输出格式:

对每个非法输入,在一行中输出“ERROR: X is not a legal number”,其中X是输入。最后在一行中输出结果:“The average of K numbers is Y”,其中K是合法输入的个数,Y是它们的平均值,精确到小数点后2位。如果平均值无法计算,则用“Undefined”替换Y。如果K为1,则输出“The average of 1 number is Y”。

输入样例1:

7
5 -3.2 aaa 9999 2.3.4 7.123 2.35

输出样例1:

ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38

输入样例2:

2
aaa -9999

输出样例2:

ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined

程序代码:

#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<math.h>
char c[100000];
char ans[1000];
void  getNum(char* p,int *a);
double check(char ans[]);
int main()
{
    int n;
    scanf("%d",&n);
    getchar();
    gets(c);
    char *p =c;
    int a=0;
    double sum = 0; 
    int count = 0;
    while(*p!='\0')
    {
        getNum(p,&a);
        if(check(ans)!=0)
        {
            count++;
            sum = sum +atof(ans);
        }
        p = p+a;
    }
    double ave = 0;
    if(count == 0)
    {
        printf("The average of 0 numbers is Undefined\n");
    }
    else
    {
        ave = sum/count;
        if(count == 1)
            printf("The average of 1 number is %.2f\n",ave);
        else
            printf("The average of %d numbers is %.2f\n",count,ave);

    }
    return 0;
}
void getNum(char* p,int *a)
{
    *a = 0;
    int j=0, sum = 0,flag = 1;
    memset(ans,0,1000);
    while(*p==' ')
    {
        p++;    
        (*a)++;
    }
    while(*p!=' '&&*p!='\0')
    {
        ans[j++]=*p;
        /*if(*p<'0'||*p>'9') flag = 0; else sum = sum *10 + *p - '0';*/
        p++;
        (*a)++;
    }
    ans[j] = '\0';
/* if(flag==1) return sum ; else { printf("ERROR: %s is not a legal number\n",ans); return 0; }*/
}
double check(char ans[])
{
    int len = strlen(ans);
    double sum = 0.0;
    int count = 0;
    int dot = 0,i=0;
    if(ans[0]=='-')
    {
        i=1;
        if(strlen(ans)==1)
        {
            printf("ERROR: %s is not a legal number\n",ans);
            return 0;
        }
    }
    for(;i<len;i++)
    {
        if(ans[i]>'9'||ans[i]<'0')
        {
            if(ans[i]!='.')
            {
                printf("ERROR: %s is not a legal number\n",ans);
                return 0;
            }
            else if(dot == 1)
            {
                printf("ERROR: %s is not a legal number\n",ans);
                return 0;
            }
            else
            {
                dot = 1;
            }
        }
        else
        {
            if(dot == 1)
                count++;
        }
    }
    if(count>2)
    {
        printf("ERROR: %s is not a legal number\n",ans);
        return 0;
    }
    sum = atof(ans);
    if(sum<-1000||sum > 1000)
    {
        printf("ERROR: %s is not a legal number\n",ans);
        return 0;
    }
    else 
        return 1;       
}