Face The Right Way

Time Limit: 2000MS Memory Limit: 65536K

Description

Farmer John has arranged his N (1 ≤ N ≤ 5,000) cows in a row and many of them are facing forward, like good cows. Some of them are facing backward, though, and he needs them all to face forward to make his life perfect.

Fortunately, FJ recently bought an automatic cow turning machine. Since he purchased the discount model, it must be irrevocably preset to turn K (1 ≤ K ≤ N) cows at once, and it can only turn cows that are all standing next to each other in line. Each time the machine is used, it reverses the facing direction of a contiguous group of K cows in the line (one cannot use it on fewer than K cows, e.g., at the either end of the line of cows). Each cow remains in the same location as before, but ends up facing the opposite direction. A cow that starts out facing forward will be turned backward by the machine and vice-versa.

Because FJ must pick a single, never-changing value of K, please help him determine the minimum value of K that minimizes the number of operations required by the machine to make all the cows face forward. Also determine M, the minimum number of machine operations required to get all the cows facing forward using that value of K.

Input

Line 1: A single integer: N
Lines 2…N+1: Line i+1 contains a single character, F or B, indicating whether cow i is facing forward or backward.

Output

Line 1: Two space-separated integers: K and M

Sample Input

7
B
B
F
B
F
B
B

Sample Output

3 3

Hint

For K = 3, the machine must be operated three times: turn cows (1,2,3), (3,4,5), and finally (5,6,7)

思路:

首先这题是一道开关灯类型问题,在输入的时候将b和f转换成数字,达成线性关系,这里设f为0, b为1。我相信主函数都能看得懂的,看看自定义函数,当取模不能整除的时候就说明要反转了,然后f[i] = 1就是说明i点反转过了一次了,res就是总反转次数了,然后因为反转过了一次,那么对后面就都会出现了影响,所以sum就是对应这种影响用的,假如i先前对其有影响的奶牛反转过了两次,那么i就和没反转一样,所以取模这个sum就没有影响了,然后就是如果没有影响的时候就要将sum-f[i - k + 1],因为i - k + 1位对下个i位没有影响了,因为i-k+1可能为负数,所以要判断,后面一个for循环是因为最后的几个无法反转了,因为数量已经不够了。

#include <iostream>
#include <cstring>
using namespace std;
int a[5010] = {0}, f[5010];
int n;
int rever(int k) {
	memset(f, 0, sizeof(f));
	int res = 0, sum = 0;
	for (int i = 0; i <= n - k; i++) {
		if ((a[i] + sum) % 2 != 0) {
			f[i] = 1;
			res++;
		}
		sum += f[i];
		if (i - k + 1>= 0) sum -= f[i - k + 1];
	}
	for (int i = n - k + 1; i < n; i++) {
		if ((a[i] + sum) % 2 != 0) return -1;
		if (i - k + 1 >= 0)  sum -= f[i - k + 1];
	}
	return res;
}
int main() {
	char c;
	scanf("%d", &n);
	for (int i = 0; i < n; i++) {
		getchar();
		scanf("%c", &c);
		if (c == 'B') a[i] = 1; 
	}
	int minm = n, mink = 1;
	for (int i = 1; i <= n; i++) {
		int m = rever(i);
		if (minm > m && m > 0) {
			minm = m;
			mink = i;
		}
	}
	cout << mink << " " << minm << endl;
	return 0;
}