题目链接:传送门

Problem Description

As the new term comes, the Ignatius Train Station is very busy nowadays. A lot of student want to get back to school by train(because the trains in the Ignatius Train Station is the fastest all over the world ^v^). But here comes a problem, there is only one railway where all the trains stop. So all the trains come in from one side and get out from the other side. For this problem, if train A gets into the railway first, and then train B gets into the railway before train A leaves, train A can't leave until train B leaves. The pictures below figure out the problem. Now the problem for you is, there are at most 9 trains in the station, all the trains has an ID(numbered from 1 to n), the trains get into the railway in an order O1, your task is to determine whether the trains can get out in an order O2.

Input

The input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input is terminated by the end of file. More details in the Sample Input.

Output

The output contains a string "No." if you can't exchange O2 to O1, or you should output a line contains "Yes.", and then output your way in exchanging the order(you should output "in" for a train getting into the railway, and "out" for a train getting out of the railway). Print a line contains "FINISH" after each test case. More details in the Sample Output.

 

Sample Input

3 123 321

3 123 312

 

Sample Output

Yes.

in

in

in

out

out

out

FINISH

No.

FINISH

题目大意:给一个数n,表示有n个火车,第一个字符串为进站顺序,第二个字符串为出站顺序,问这些火车能否可以顺利的出站和进栈,可以的话输出Yes,并输出这些火车进出站的次序。如果不能顺利进出站,直接输出No。

#include<iostream>
#include<cstdio>
#include<stack>
#include<cstring>
using namespace std;
char m[100],n[100];
int s[200];
int main()
{
    int a,b,c,d,e,f,g;
    while(cin>>a)
    {
        cin>>m>>n;
        b=strlen(m);
        stack<char>w;
        e=0;c=0;d=0;
        while(e<b)
        {
            w.push(m[e]);
            e++;
            s[d++]=1;
            while(!w.empty()&&n[c]==w.top())
            {
                c++;
                s[d++]=0;
                w.pop();
            }
        }
        if(c!=a)
        {
            cout<<"No."<<endl<<"FINISH"<<endl;
        }
        else
        {
            cout<<"Yes."<<endl;
            for(b=0;b<d;b++)
            {
                if(s[b]==1)
                    cout<<"in"<<endl;
                else
                    cout<<"out"<<endl;
            }
            cout<<"FINISH"<<endl;
        }
    }
    return 0;
}