题目链接:https://cn.vjudge.net/problem/HDU-4734

For a decimal number x with n digits (A nA n-1A n-2 ... A 2A 1), we define its weight as F(x) = A n * 2 n-1 + A n-1 * 2 n-2 + ... + A 2 * 2 + A 1 * 1. Now you are given two numbers A and B, please calculate how many numbers are there between 0 and B, inclusive, whose weight is no more than F(A).

Input

The first line has a number T (T <= 10000) , indicating the number of test cases. 
For each test case, there are two numbers A and B (0 <= A,B < 10 9)

Output

For every case,you should output "Case #t: " at first, without quotes. The t is the case number starting from 1. Then output the answer.

Sample Input

3
0 100
1 10
5 100

Sample Output

Case #1: 1
Case #2: 2
Case #3: 13

题意:求  满足x属于[0,B]区间内且F(x)不大于F(A)的     x 的个数。

 首先得知道,这个F(x)公式算出来的值最大值不会超过5000,所以数组不用开太大。

 然后就是判断了,基本思路都是套模板,递归部分就是每次用上限减去组成的数,如果是正的就加1,否则继续找,  直到全部组合完了。(上限就是F(A))

 

 

#include<cstdio>
#include<cstring>
using namespace std;
int dp[12][5000];
int a[12];
int A,B;
int f(int x){
	int p=1;
	int ans=0;
	while(x){
		ans+=(x%10)*p;
		x/=10;
		p<<=1;
	}
	return ans;
}
int dfs(int pos,int value,bool limit){
    if(value<0) return 0;
	if(pos==0) return value>=0;	
	if(!limit&&dp[pos][value]!=-1) return dp[pos][value];
	int ans=0;
	int up=limit?a[pos]:9;
	for(int i=0;i<=up;i++){
		ans+=dfs(pos-1,value-i*(1<<(pos-1)),limit&&i==up);
	}
	if(!limit) dp[pos][value]=ans;
	return ans;
}
int solve(int x){
	int pos=0;
	while(x){
		a[++pos]=x%10;
		x/=10;
	}
	return dfs(pos,f(A),true);
}
int main(){
	int T;
	memset(dp,-1,sizeof(dp));
	scanf("%d",&T);
	for(int i=1;i<=T;i++){
		scanf("%d%d",&A,&B);
		printf("Case #%d: %d\n",i,solve(B));
	}
	return 0;
}