题干:

Message queue is the basic fundamental of windows system. For each process, the system maintains a message queue. If something happens to this process, such as mouse click, text change, the system will add a message to the queue. Meanwhile, the process will do a loop for getting message from the queue according to the priority value if it is not empty. Note that the less priority value means the higher priority. In this problem, you are asked to simulate the message queue for putting messages to and getting message from the message queue.

 

Input

 

There's only one test case in the input. Each line is a command, "GET" or "PUT", which means getting message or putting message. If the command is "PUT", there're one string means the message name and two integer means the parameter and priority followed by. There will be at most 60000 command. Note that one message can appear twice or more and if two messages have the same priority, the one comes first will be processed first.(i.e., FIFO for the same priority.) Process to the end-of-file.

 

Output

 

For each "GET" command, output the command getting from the message queue with the name and parameter in one line. If there's no message in the queue, output "EMPTY QUEUE!". There's no output for "PUT" command.

 

Sample Input

 

GET
PUT msg1 10 5
PUT msg2 10 4
GET
GET
GET

 

Sample Output

 

EMPTY QUEUE!
msg2 10
msg1 10
EMPTY QUEUE!

解题报告:

   优先队列直接解。刚开始数组开太大了疯狂超内存。我还在node上加了个[MAX]  出现了这个报错 Segmentation Fault

AC代码:

#include<bits/stdc++.h>

using namespace std;
const int MAX = 6e4 + 5;
struct Node {
	int id;
	char name[400];
	int k;//参数
	int vip;
	//Node(int id,char name[MAX],int k,int vip):id(id),name(name),k(k),vip(vip){}
	bool operator<(const Node b) const {
		if(vip!=b.vip) return vip>b.vip;
		return id>b.id;
	}
} node;
priority_queue <Node> pq;
char tmpname[MAX];
int main()
{
	char op[10];
	int cnt = 0;
	int k,v;
	
	while(~scanf("%s",op) ) {
		if(op[0] == 'G') {
			if(!pq.empty() ) {
				Node cur = pq.top();
				pq.pop();
				printf("%s %d\n",cur.name,cur.k);
			}
			else printf("EMPTY QUEUE!\n");
		}
		else {
			cnt++;
			scanf("%s%d%d",tmpname,&k,&v);
			
			Node tmp;
			tmp.id = cnt;tmp.k = k;tmp.vip = v;
			strcpy(tmp.name,tmpname);
			pq.push(tmp);
		}
		
	}
	return 0 ;
}