Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 26063 Accepted: 17394
文章目录
Poj 3070 Fibonacci
Description
In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 +
Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci
sequence are:0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …
An alternative formula for the Fibonacci sequence is
.Given an integer n, your goal is to compute the last 4 digits of Fn.
Input
The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.
Output
For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).
Sample Input
0
9
999999999
1000000000
-1
Sample Output
0
34
626
6875
Hint
As a reminder, matrix multiplication is associative, and the product
of two 2 × 2 matrices is given by
.Also, note that raising any 2 × 2 matrix to the 0th power gives the
identity matrix:
题意:
其实就是求第x位斐波那契数列(记得mod10000),不过题目给你介绍了矩阵的相关知识,以及矩阵与斐波那契数列的联系,就是让你用矩阵快速幂来求斐波那契数列。
题解:
斐波那契数列的博客
我在这个博客里详细介绍了三种斐波那契数列的求法,其中就有矩阵快速幂的方法
所以我在这就不详细介绍,简单说说:
mul(a,b)是用来进行矩阵a与b的乘法运算
pow(mat a,ll n)//快速幂求矩阵a的n次幂
代码:
#include <iostream>
#include <cstddef>
#include <cstring>
#include <vector>
using namespace std;
typedef long long ll;
const int mod=10000;
typedef vector<ll> vec;
typedef vector<vec> mat;
mat mul(mat &a,mat &b)
{
mat c(a.size(),vec(b[0].size()));
for(int i=0; i<2; i++)
{
for(int j=0; j<2; j++)
{
for(int k=0; k<2; k++)
{
c[i][j]+=a[i][k]*b[k][j];//矩阵的运算法则
c[i][j]%=mod;
}
}
}
return c;
}
mat pow(mat a,ll n)
{
mat res(a.size(),vec(a.size()));
for(int i=0; i<a.size(); i++)
res[i][i]=1;
while(n)
{
if(n&1) res=mul(res,a);
a=mul(a,a);
n/=2;
}
return res;
}
ll solve(ll n)
{
mat a(2,vec(2));
a[0][0]=1;
a[0][1]=1;
a[1][0]=1;
a[1][1]=0;
a=pow(a,n);
return a[0][1];
}
int main()
{
ll n;
while(cin>>n&&n!=-1)
{
cout<<solve(n)<<endl;
}
return 0;
}