The Suspects

Time Limit: 1000MS Memory Limit: 20000K Total Submissions: 57377 Accepted: 27226

Description

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).
Once a member in a group is a suspect, all members in the group are suspects.
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.
Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.
Output

For each case, output the number of suspects in one line.
Sample Input

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0
Sample Output

4
1
1

题目大意:
上来先输入n,m代表有n个人,和m个小组,对他们进行编号从0到n-1,0是感染源,只要和0在同一个小组的人都会被感染,题目要你求每组样例一共有多少人被感染了。

思路:
因为只要0出现在某个组,整个组就全部会被感染,所以把所有组并起来,然后遍历所有人,时间复杂度O(n),只要第i个人的父节点和0的父节点一样那么说明第i个人被感染了,对感染的人求个和就好了。

代码:

#include<iostream> 
#include<string.h>
using namespace std;
const int maxn = 30000 + 10;
int parent[maxn];
int id[maxn];
int k;
void defin(int n)
{
	for (int i = 0; i < n; i++)
	{
		parent[i] = i;
	}
}

int find_x(int x)
{
	if (x != parent[x])
	{
		parent[x] = find_x(parent[x]);
	}
	return parent[x];
}

int main()
{
	int n, m;
	while (cin >> n >> m)
	{
		if (n == 0 && m == 0)break;
		memset(id, 0, sizeof(id));
		memset(parent, 0, sizeof(parent));
		defin(n);
		for (int i = 0; i < m; i++)
		{
			cin >> k;
			for (int i = 0; i < k; i++)
			{
				cin >> id[i];
			}
			for (int i = 1; i < k; i++)
			{
				int a = find_x(id[i - 1]);
				int b = find_x(id[i]);
				if (a != b)
				{
					parent[a] = b;
				}
			}
		}
		int ans = 0;
		for (int i = 0; i < n; i++)
		{
			if (find_x(0) == find_x(i) || find_x(i) == 0)
				ans++;
		}
		cout << ans << endl;

	}
}