Problem Description
A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles:

Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.
 

Input
The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1 <= n <= 100000. Then follow n integers h1, ..., hn, where 0 <= hi <= 1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1. A zero follows the input for the last test case.
 

Output
For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.
 

Sample Input
7 2 1 4 5 1 3 3 4 1000 1000 1000 1000 0
 

Sample Output
8 4000

本来做的是1505 据说1505是1506的升级版 1505没做出来 才看的1506

看了描述就知道 其实本质真的很像 之前就一直纠结怎么写状态转移方程 dp[i]=max(dp[i-1],dp[i])之类的是怎么推导出来的 然后卡了好久  

度娘说找到h[i]左右与自己连着的而且比自己大的数  长度乘以该数的值 找最大的那个 还是不懂 

思维局限在一定有那么一个叫做dp的数组可以“逐个”的求出 ——这一怪圈中

不曾想其实是有两个数组用来存储位置的 orz for循环里面的while用的太好了

还有 1.long long 

         2.t>1 t<n的循环条件

#include <iostream>
#include<cstdio>
#include<cstring>
using namespace std;
long long h[100005],maxn;
int l[100005],r[100005];
int main()
{
   // freopen("cin.txt","r",stdin);
    long long n;
    while(~scanf("%I64d",&n))
    {
        if(n==0) break;
        for(int i=1;i<=n;i++) scanf("%I64d",&h[i]);
        l[1]=1,r[n]=n;
        maxn=0;
        for(int i=2;i<=n;i++)
        {
            int t=i;
            while(h[t-1]>=h[i]&&t>1) t=l[t-1];
            l[i]=t;
        }
        for(int i=n-1;i>=1;i--)
        {
            int t=i;
            while(h[t+1]>=h[i]&&t<n) t=r[t+1];
            r[i]=t;
        }
        for(int i=1;i<=n;i++)
            if((r[i]-l[i]+1)*h[i]>maxn) maxn=(r[i]-l[i]+1)*h[i];
        printf("%I64d\n",maxn);
    }
    return 0;
}