题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=4763
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Problem Description

It's time for music! A lot of popular musicians are invited to join us in the music festival. Each of them will play one of their representative songs. To make the programs more interesting and challenging, the hosts are going to add some constraints to the rhythm of the songs, i.e., each song is required to have a 'theme section'. The theme section shall be played at the beginning, the middle, and the end of each song. More specifically, given a theme section E, the song will be in the format of 'EAEBE', where section A and section B could have arbitrary number of notes. Note that there are 26 types of notes, denoted by lower case letters 'a' - 'z'.

To get well prepared for the festival, the hosts want to know the maximum possible length of the theme section of each song. Can you help us?

Input

The integer N in the first line denotes the total number of songs in the festival. Each of the following N lines consists of one string, indicating the notes of the i-th (1 <= i <= N) song. The length of the string will not exceed 10^6.

Output

There will be N lines in the output, where the i-th line denotes the maximum possible length of the theme section of the i-th song.

Sample Input

5
xy
abc
aaa
aaaaba
aaxoaaaaa

Sample Output

0
0
1
1
2

Problem solving report:

Description: 给你一个字符串,找出最长的子串长度。该子串需满足:在串的开头和中间和结尾分别出现一次,且不能交叉。
Problem solving: 很简单的KMP。我们考虑匹配第len个位置的前后缀。去掉开头和结尾的前后缀,只需在剩下的中间部分找有没有匹配的子串。如果有说明满足条件,否则就回溯减小前后缀的长度。

Accepted Code:

#include <bits/stdc++.h>
using namespace std;
const int MAXN = 1000005;
int nex[MAXN];
char str[MAXN];
void Next(int n) {
    nex[0] = -1;
    int i = 0, j = -1;
    while (i < n) {
        if (~j && str[i] != str[j])
            j = nex[j];
        else nex[++i] = ++j;
    }
}
bool KMP(char sa[], char sb[], int la, int lb) {
    int i = 0, j = 0;
    while (i < la) {
        if (~j && sa[i] != sb[j])
            j = nex[j];
        else i++, j++;
        if (j >= lb)
            return true;
    }
    return false;
}
int main() {
    int t, len;
    scanf("%d", &t);
    while (t--) {
        scanf("%s", str);
        len = strlen(str);
        Next(len);
        int l = nex[len];
        while (l) {
            if (len >= 3 * l && KMP(str + l, str, len - 2 * l, l))
                break;
            l = nex[l];
        }
        printf("%d\n", l);
    }
    return 0;
}