Problem Description

Many geometry(几何)problems were designed in the ACM/ICPC. And now, I also prepare a geometry problem for this final exam. According to the experience of many ACMers, geometry problems are always much trouble, but this problem is very easy, after all we are now attending an exam, not a contest :)
Give you N (1<=N<=100) segments(线段), please output the number of all intersections(交点). You should count repeatedly if M (M>2) segments intersect at the same point.

Note:
You can assume that two segments would not intersect at more than one point. 

 

 

Input

Input contains multiple test cases. Each test case contains a integer N (1=N<=100) in a line first, and then N lines follow. Each line describes one segment with four float values x1, y1, x2, y2 which are coordinates of the segment’s ending. 
A test case starting with 0 terminates the input and this test case is not to be processed.

 

 

Output

For each case, print the number of intersections, and one line one case.

 

 

Sample Input


 

2 0.00 0.00 1.00 1.00 0.00 1.00 1.00 0.00 3 0.00 0.00 1.00 1.00 0.00 1.00 1.00 0.000 0.00 0.00 1.00 0.00 0

 

 

Sample Output


 

1 3

题意:判断给出的n个线段有几个交点

代码:

#include<iostream>
#include<algorithm>
#include<cstring>
#include<string>
#include<cstdio>
#include<cmath>
#include<set>
#include<map>
using namespace std;
#define inf 0x3f3f3f3f
#define ll long long

struct ac
{
	double x1,y1,x2,y2;
}p[105];

double ps(ac a,ac b)    //跨立实验
{
	if(((a.x1-b.x1)*(a.y2-b.y1)-(a.x2-b.x1)*(a.y1-b.y1))*((a.x1-b.x2)*(a.y2-b.y2)-(a.x2-b.x2)*(a.y1-b.y2))<=0&&((b.x1-a.x1)*(b.y2-a.y1)-(b.x2-a.x1)*(b.y1-a.y1))*((b.x1-a.x2)*(b.y2-a.y2)-(b.x2-a.x2)*(b.y1-a.y2))<=0)
	return 1;
	return 0;
}
int main()
{
	int n,i,j,s;
	while(cin>>n&&n)
	{
		s=0;
		for(i=0;i<n;i++)
			cin>>p[i].x1>>p[i].y1>>p[i].x2>>p[i].y2;
		for(i=0;i<n;i++)
		{
			for(j=i+1;j<n;j++)
			{
				if(ps(p[i],p[j]))
				s++;
			}
		}
		cout<<s<<endl;
	}
	return 0;
}