Fibonacci

Time Limit: 1000MS Memory Limit: 65536K

Description

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

.

Given an integer n, your goal is to compute the last 4 digits of Fn.

Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output

For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input

0
9
999999999
1000000000
-1

Sample Output

0
34
626
6875

Hint

As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by

.

Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:

思路:

快速矩阵幂,其实就是快速幂的加强版,比如斐波那契数列,当n较小的时候,可以直接递推,但是太大的话递推的内存还是时间就有点不够用了,所以就要用快速幂的方式,将时间以及空间大大减少,快速幂要求的是每次乘得数要是一样的,这样才可用快速幂,所以就用矩阵的方式将每次相乘的底数计算出来,再用快速幂的方式计算出最后的值。

#include <iostream>
#include <vector>
using namespace std;
const int mod = 10000;
const int maxn = 110;
typedef long long ll;
int n;
typedef vector<int> vec;
typedef vector<vec> mat; 
mat mul(mat a, mat b) {
	mat c(a.size(), vec(b[0].size()));
	for (int i = 0; i < a.size(); i++) {
		for (int j = 0; j < b[0].size(); j++) {
			for (int k = 0; k < b.size(); k++) {
				c[i][j] = (c[i][j] + a[i][k] * b[k][j]) % mod;
			}
		}
	}
	return c;
}
mat pow(mat a, int n) {
	mat b(a.size(), vec(a[0].size()));
	for (int i = 0; i < a.size(); i++) b[i][i] = 1;
	while (n) {
		if (n & 1) b = mul(a, b);
		a = (mul(a, a));
		n >>= 1;
	}
	return b;
}
int main() {
	while (scanf("%d", &n) != EOF && n != -1) {
		mat a(2, vec(2));
		a[0][0] = 1, a[0][1] = 1;
		a[1][0] = 1; a[1][1] = 0;
		a = pow(a, n);
		cout << a[1][0] <<endl;
	}
	return 0;
}