Minimum’s Revenge
There is a graph of n vertices which are indexed from 1 to n. For any pair of different vertices, the weight of the edge between them is the
least common multiple of their indexes.

Mr. Frog is wondering about the total weight of the minimum spanning tree. Can you help him?

Input
The first line contains only one integer T (T≤100T≤100), which indicates the number of test cases.

For each test case, the first line contains only one integer n (2≤n≤1092≤n≤109), indicating the number of vertices.

Output
For each test case, output one line “Case #x:y”,where x is the case number (starting from 1) and y is the total weight of the minimum spanning tree.

Sample Input
2
2
3

Sample Output
Case #1: 2
Case #2: 5

Hint
In the second sample, the graph contains 3 edges which are (1, 2, 2), (1, 3, 3) and (2, 3, 6). Thus the answer is 5.

因为每个节点都与第一个节点有连接,所以最小的权值之和即每个节点与第一个节点连线的权值之和。

#include<cstdio>
#include<iostream>
#include<cstring>
using namespace std;
int main()
{
   
    long long n,t,m,i;
    scanf("%lld",&t);
    for(i=1;i<=t;i++)
    {
   
        scanf("%lld",&n);
        m=(n+2)*(n-1)/2;
        cout<<"Case #"<<i<<": "<<m<<'\n';
    }
    return 0;
}