A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.
Input
The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.
Output
For each the case the program has to print the result on separate line of the output file.if no answer, print 0.
Sample Input
2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5

Sample Output

2

3

1.尺取法:



例如:n = 5 m = 11

    1  2  3  4  5

sum[s++] += a[i]//当sum[s] > m 时停止,这里是1 2 3 4 5.如果小于就说明没有

sum[s] -= a[t++]//每执行这个就判断一下上面那个条件是否满足

//不断更新它的长度 min(res,t-s)

//像毛毛虫一样 , 慢慢往后加,前面减

下面是尺取法的代码:

#include <stdio.h>
#include <iostream>
using namespace std;
int main ()
{
	
	long long int n , m , T ,a[100055] , res;
	scanf("%lld" , &T);
	while(T--)
	{
long long int t = 0 , s = 0 ,sum = 0 ;
		scanf("%lld %lld" , &n , &m);
		for(int i = 0 ; i < n ; i++)
		{
			scanf("%lld" , &a[i]);
		}
		res = n + 1;
		while(1)
		{
			while(t < n && sum < m)
			{
				sum += a[t];
				t++;
			}
			if(sum < m)
			{
			//	printf("0\n");
				break;
			}
			res = min(res,t-s);
			sum -= a[s];
			s++;
		}
		if(res > n)
		{
			res = 0;
		}
			printf("%lld\n" , res);
	}

	return 0;
}

2.前缀和加二分法

二分找t的最小位置(sum[s] + S)

#include <stdio.h>
#include <cstring>
#include <algorithm>
#include <stdlib.h>
#include <iostream>
using namespace std;
const int maxn = 100005; 
int main()
{
	int n , m ,T, sum[maxn] , a[maxn] , res;
	scanf("%d" , &T);
	while(T--)
	{
		int flag = 0;
		scanf("%d %d" , &n , &m);
		for(int i = 0 ; i < n ; i++)
		{
			scanf("%d" ,&a[i] );
		} 
		for(int i = 0 ; i < n ; i++)
		{
			sum[i+1] = sum[i] + a[i];//sum 1-n
		}
		if(sum[n] <= m)
		{
		flag = 1;
			
		}
		 res = n;
		for(int s = 0 ; sum[s] + m <= sum[n] ; s++)
		{
			int t = lower_bound(sum+s , sum + n , sum[s] + m) - sum;
			res = min(res , t-s);
		}
		if(flag ==1 )
		{
			printf("0\n");
		}
		else
		{
			printf("%d\n" , res);
		}
		
	}
	return 0;
}