Prime Distance

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 30738 Accepted: 7862
Description

The branch of mathematics called number theory is about properties of numbers. One of the areas that has captured the interest of number theoreticians for thousands of years is the question of primality. A prime number is a number that is has no proper factors (it is only evenly divisible by 1 and itself). The first prime numbers are 2,3,5,7 but they quickly become less frequent. One of the interesting questions is how dense they are in various ranges. Adjacent primes are two numbers that are both primes, but there are no other prime numbers between the adjacent primes. For example, 2,3 are the only adjacent primes that are also adjacent numbers.
Your program is given 2 numbers: L and U (1<=L< U<=2,147,483,647), and you are to find the two adjacent primes C1 and C2 (L<=C1< C2<=U) that are closest (i.e. C2-C1 is the minimum). If there are other pairs that are the same distance apart, use the first pair. You are also to find the two adjacent primes D1 and D2 (L<=D1< D2<=U) where D1 and D2 are as distant from each other as possible (again choosing the first pair if there is a tie).
Input

Each line of input will contain two positive integers, L and U, with L < U. The difference between L and U will not exceed 1,000,000.
Output

For each L and U, the output will either be the statement that there are no adjacent primes (because there are less than two primes between the two given numbers) or a line giving the two pairs of adjacent primes.
Sample Input

2 17
14 17
Sample Output

2,3 are closest, 7,11 are most distant.
There are no adjacent primes.
Source
Waterloo local 1998.10.17

题意分析:

因为数字很大,而区间最多是1e6,比较小,所以从区间着手,筛去区间中的所有合数,剩下的就是素数。

筛合数可以先筛出所有的素数,再筛去他们的倍数。

而数字不超过2,147,483,647,所以质因数不会超过sqrt(2,147,483,647),大约是40000多,所以用埃氏筛法筛出50000以内的所有素数,再通过这些素数筛去所有的合数。
<mark>注意</mark>
特判一下 左端点是否为一

if (l== 1)
		dashu[0] = 1;

接下来看代码

#include<iostream>
#include<math.h>
#include<stdio.h>
#include<string.h>
#include <algorithm>
#define ll long long int
#define inf 0x3f3f3f3f
const int mod=998244353;
using namespace std;
const int maxn=1e6+10;
const double pi = 3.1415926535898;
const int dx[9]={0,1,1,2,2,-1,-1,-2,-2};
const int dy[9]={0,2,-2,1,-1,2,-2,1,-1};

bool isprime[10000000];
ll n,m,sum,p,t,h,cnt,q,num;
ll Prime[maxn],s1,s2,p1,p2;
//char str[110][100],s[maxn],ss[maxn];
ll num_prime[maxn],prime[maxn],dashu[maxn];

void isPrime(ll k){
	for(int i=2;i<=k;i++)
	{
		if(isprime[i]==0) prime[++cnt]=i;
		for(int j=1;j<=cnt&&i*prime[j]<=k;j++)
		{
			isprime[i*prime[j]]=1;
			if(i%prime[j]==0) break;
		}
	}
}

void f(ll l,ll r){
	memset(dashu,0,sizeof(dashu));
	for(int i=1;i<=cnt;i++)
	{
		ll s=l/prime[i];
		if(s<=1) s=2;
		for(ll j=s*prime[i];j<=r;j+=prime[i])
		{
			if(j>=l) dashu[j-l]=1;	
		}
	}
	if (l== 1)
		dashu[0] = 1;
	num=0;
	for(int i=0;i<=r-l;i++)
	{
		if(!dashu[i]) num_prime[++num]=i+l;
	}
	if(num<=1) printf("There are no adjacent primes.\n");//一对素数 
	else{
		ll maxx=-0x3f3f3f3f,minn=0x3f3f3f3f,x1,y1,x2,y2;
		for(int i=1;i<num;i++)
		{
			ll o=num_prime[i+1]-num_prime[i];
			if(o>maxx){
				x1=num_prime[i],y1=num_prime[i+1];
				maxx=o;
			}
			if(o<minn){
				x2=num_prime[i],y2=num_prime[i+1];
				minn=o;
			}
		}
		printf("%lld,%lld are closest, %lld,%lld are most distant.\n", x2, y2, x1, y1);
	}
}

int main(){
	isPrime(maxn);
	while(~scanf("%lld%lld",&n,&m))
		f(n,m);
	return 0;
}