Description:

Michael喜欢滑雪百这并不奇怪, 因为滑雪的确很刺激。可是为了获得速度,滑的区域必须向下倾斜,而且当你滑到坡底,你不得不再次走上坡或者等待升降机来载你。Michael想知道载一个区域中最长底滑坡。区域由一个二维数组给出。数组的每个数字代表点的高度。下面是一个例子

1 2 3 4 5

16 17 18 19 6

15 24 25 20 7

14 23 22 21 8

13 12 11 10 9

一个人可以从某个点滑向上下左右相邻四个点之一,当且仅当高度减小。在上面的例子中,一条可滑行的滑坡为24-17-16-1。当然25-24-23-…-3-2-1更长。事实上,这是最长的一条。

Input:

输入的第一行表示区域的行数R和列数C(1 <= R,C <= 100)。下面是R行,每行有C个整数,代表高度h,0<=h<=10000。

Output:

输出最长区域的长度。

Sample Input:

5 5
1 2 3 4 5
16 17 18 19 6
15 24 25 20 7
14 23 22 21 8
13 12 11 10 9

Sample Output:

25

题目链接

遍历记忆化深搜找最长路径。

AC代码:

//#include <bits/stdc++.h>
#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
using namespace std;
#define mem(a,b) memset(a,b,sizeof(a))
#define pb push_back
#define mp make_pair
typedef long long ll;
typedef unsigned long long ull;
typedef pair<int,int> P;
const int INF = 0x3f3f3f3f;
const int maxn = 102;
const int mod = 1e9+7;
const double eps = 1e-8;
const double pi = asin(1.0)*2;
const double e = 2.718281828459;
void fre() {
    freopen("in.txt", "r", stdin);
    //freopen("out.txt", "w", stdout);
}

int t;
int r, c;
int ans;
int maze[maxn][maxn];
int dp[maxn][maxn];

int _abs(int a) {
	return a >= 0 ? a : -a;
}

int dfs(int x, int y, int h) {
	if (x < 0 || y < 0 || x >= r || y >= c || h <= maze[x][y]) {
		return 0;
	}
	if (dp[x][y] >= 0) {
		return dp[x][y];
	}
	for (int i = -1; i < 2; ++i) {
		for (int j = -1; j < 2; ++j) {
			if (_abs(i) != _abs(j)) {
				int nx = x + i, ny = y + j;
				int temp = dfs(nx, ny, maze[x][y]) + 1;
				dp[x][y] = temp > dp[x][y] ? temp : dp[x][y];
			}
		}
	}
	return dp[x][y];
}

int main() {
	//fre();
	while (~scanf("%d%d", &r, &c)) {
		ans = 0;
		mem(dp, -1);
		mem(maze, 0);
		for (int i = 0; i < r; ++i) {
			for (int j = 0; j < c; ++j) {
				scanf("%d", &maze[i][j]);
			}
		}
		for (int i = 0; i < r; ++i) {
			for (int j = 0; j < c; ++j) {
				int temp = dfs(i, j, INF);
				if (temp > ans) {
					ans = temp;
				}
			}
		}
		printf("%d\n", ans);
	}
    return 0;
}