Training little cats

Time Limit: 2000MS Memory Limit: 65536K

Description

Facer’s pet cat just gave birth to a brood of little cats. Having considered the health of those lovely cats, Facer decides to make the cats to do some exercises. Facer has well designed a set of moves for his cats. He is now asking you to supervise the cats to do his exercises. Facer’s great exercise for cats contains three different moves:
g i : Let the ith cat take a peanut.
e i : Let the ith cat eat all peanuts it have.
s i j : Let the ith cat and jth cat exchange their peanuts.
All the cats perform a sequence of these moves and must repeat it m times! Poor cats! Only Facer can come up with such embarrassing idea.
You have to determine the final number of peanuts each cat have, and directly give them the exact quantity in order to save them.

Input

The input file consists of multiple test cases, ending with three zeroes “0 0 0”. For each test case, three integers n, m and k are given firstly, where n is the number of cats and k is the length of the move sequence. The following k lines describe the sequence.
(m≤1,000,000,000, n≤100, k≤100)

Output

For each test case, output n numbers in a single line, representing the numbers of peanuts the cats have.

Sample Input

3 1 6
g 1
g 2
g 2
s 1 2
g 3
e 2
0 0 0

Sample Output

2 0 1

思路:

快速矩阵幂的一道题目,首先就是如何求出这个矩阵,有题目可以知道这三种状态可以用矩阵表示比如:
吃花生:
1 0 0 1 cat1
0 1 0 0 cat2
0 0 1 0 cat3
0 0 0 1 1
交换花生就是:
1 0 0 0 cat1
0 0 1 0 cat2
0 1 0 0 cat3
0 0 0 1 1
吃掉花生就是:
1 0 0 0 cat1
0 0 0 0 cat2
0 0 1 0 cat3
0 0 0 1 1
这样的话矩阵就求出来了,然后就是重复n次,但是这题的话极容易超时,原来我的思路是把最后的矩阵算出来,但是最后超时了,所以只能改成求最后一列的矩阵,这样时间复杂度就小了,注意vector的使用,本题vector也容易超时。

#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;
__int64 a[105][105], b[105], d[105], c[105][105];
__int64 n, k, m;
void pow(__int64 x) {
	while (x) {
		if (x & 1) {
			for (int i = 0; i <= n; i++) {
				d[i] = 0;
				for (int j = 0; j <= n; j++) {
					d[i] += a[i][j] * b[j];
				}
			}
			for (int i = 0; i <= n; i++) b[i] = d[i];
		}
		memset(c, 0, sizeof(c));
		for (int i = 0; i <= n; i++) {
			for (int j = 0; j <= n; j++) {
				if (a[i][j] == 0) continue;
				for (int k = 0; k <= n; k++) {
					c[i][k] += a[i][j] * a[j][k];
				} 
			}
		}
		for (int i = 0; i <= n; i++) {
			for (int j = 0; j <= n; j++) {
				a[i][j] = c[i][j];
			}
		}
		x >>= 1;
	}
}
int main() {
	while (scanf("%I64d %I64d %I64d", &n, &m, &k) != EOF && n + m + k) {
		char c;
		memset(a, 0, sizeof(a));
		memset(b, 0, sizeof(b));
		for (int i = 0; i <= n; i++) a[i][i] = 1;
		while (k--) {
			__int64 x;
			getchar();
			scanf("%c %I64d", &c, &x);
			if (c == 'g') a[x - 1][n]++;
			else if (c == 'e') {
				for (int j = 0; j <= n; j++) a[x - 1][j] = 0;
			}
			else {
				__int64 y;
				scanf("%I64d", &y);
				for (int j = 0; j <= n; j++) {
					swap(a[x - 1][j], a[y - 1][j]);
				}
			}
		}
		b[n] = 1;
		pow(m);
		for (int i = 0; i < n; i++) {
			if (i != 0) printf(" ");
			printf("%I64d", b[i]);
		}
		printf("\n");
	} 
	return 0;
}