题目链接:https://cn.vjudge.net/contest/304471#problem/H

The multiplication puzzle is played with a row of cards, each containing a single positive integer. During the move player takes one card out of the row and scores the number of points equal to the product of the number on the card taken and the numbers on the cards on the left and on the right of it. It is not allowed to take out the first and the last card in the row. After the final move, only two cards are left in the row.

The goal is to take cards in such order as to minimize the total number of scored points.

For example, if cards in the row contain numbers 10 1 50 20 5, player might take a card with 1, then 20 and 50, scoring

10*1*50 + 50*20*5 + 10*50*5 = 500+5000+2500 = 8000


If he would take the cards in the opposite order, i.e. 50, then 20, then 1, the score would be

1*50*20 + 1*20*5 + 10*1*5 = 1000+100+50 = 1150.

Input

The first line of the input contains the number of cards N (3 <= N <= 100). The second line contains N integers in the range from 1 to 100, separated by spaces.

Output

Output must contain a single integer - the minimal score.

Sample Input

6
10 1 50 50 20 5

Sample Output

3650

dp[l][r]表示使l和r 相邻所需要花费的最小代价

#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
typedef long long ll;
ll a[105];
ll dp[105][105];
ll dfs(int l,int r){
	if(dp[l][r]!=-1) return dp[l][r];
	if(r-l==1) return dp[l][r]=0;
	ll ans=1e15;
	for(int i=l+1;i<r;i++){
		ans=min(ans,dfs(l,i)+dfs(i,r)+a[l]*a[i]*a[r]);
	}
	return dp[l][r]=ans;
}
int main(){
	int n;
	scanf("%d",&n);
	memset(dp,-1,sizeof(dp));
	for(int i=1;i<=n;i++) scanf("%lld",&a[i]);
	printf("%lld\n",dfs(1,n));
	return 0;
}