Bone Collector

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 52215    Accepted Submission(s): 22001


Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?
<center> </center>
 

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output
One integer per line representing the maximum of the total value (this number will be less than 2 31).
 

Sample Input
1 5 10 1 2 3 4 5 5 4 3 2 1
 

Sample Output
14
 

Author
Teddy
 

Source

HDU 1st “Vegetable-Birds Cup” Programming Open Contest 



思路:

这道题是最基本的01背包模板题,直接套模板即可。


代码:

#include<iostream>  
#include<string>  
#include<cstdio>  
#include<cstring>  
#include<map>  
#include<queue>  
#include<cmath>  
#include<stack>  
#include<set>  
#include<vector>  
#include<algorithm>  
#define LL long long  
#define inf 1<<29  
using namespace std;  
const int N=1005;  
int n,m,a,b,c;  
int cost[N];  
int v[N];  
int dp[N][N];  
int main()  
{  
    int t,w;  
    scanf("%d",&t) ; 
    while(t--){  
        scanf("%d",&n);
		scanf("%d",&w);   
        int sum=0;  
        for(int i=1;i<=n;i++) scanf("%d",&v[i]) ;  
        for(int i=1;i<=n;i++) scanf("%d",&cost[i]) ;  
        memset(dp,0,sizeof(dp));  
        dp[0][0]=0;  
        for(int i=1;i<=n;i++)  
            for(int j=w;j>=0;j--)  
		   {
		   	if(j>=cost[i])dp[i][j]=max(dp[i-1][j],dp[i-1][j-cost[i]]+v[i]);
		   	else dp[i][j]=dp[i-1][j];
		   }   
        printf("%d\n",dp[n][w]);  
    }  
    return 0;  
}