Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13554    Accepted Submission(s): 6357


 

Problem Description
Consider a group of N students and P courses. Each student visits zero, one or more than one courses. Your task is to determine whether it is possible to form a committee of exactly P students that satisfies simultaneously the conditions:

. every student in the committee represents a different course (a student can represent a course if he/she visits that course)

. each course has a representative in the committee

Your program should read sets of data from a text file. The first line of the input file contains the number of the data sets. Each data set is presented in the following format:

P N
Count1 Student1 1 Student1 2 ... Student1 Count1
Count2 Student2 1 Student2 2 ... Student2 Count2
......
CountP StudentP 1 StudentP 2 ... StudentP CountP

The first line in each data set contains two positive integers separated by one blank: P (1 <= P <= 100) - the number of courses and N (1 <= N <= 300) - the number of students. The next P lines describe in sequence of the courses . from course 1 to course P, each line describing a course. The description of course i is a line that starts with an integer Count i (0 <= Count i <= N) representing the number of students visiting course i. Next, after a blank, you'll find the Count i students, visiting the course, each two consecutive separated by one blank. Students are numbered with the positive integers from 1 to N.

There are no blank lines between consecutive sets of data. Input data are correct.

The result of the program is on the standard output. For each input data set the program prints on a single line "YES" if it is possible to form a committee and "NO" otherwise. There should not be any leading blanks at the start of the line.

An example of program input and output:
 

 

Sample Input
 
2
3 3
3 1 2 3
2 1 2
1 1
3 3
2 1 3
2 1 3
1 1
 

 

Sample Output
 
YES
NO
 
 
我现在才学二分图(好羞耻 ≡[。。]≡ )
 
 
(kuangbin模板:
 
邻接矩阵:
 
#include <bits/stdc++.h>
using namespace std;
typedef long long ll;
const int inf = 0x3f3f3f3f;
const int mod = 1e9 +7;
const int N = 320;

int g[N][N];    //邻接矩阵存图
int linker[N];  //匹配到的妹子
bool vis[N];    
int p, n;       //p男生数/课程数  n女生数/人数

bool dfs(int u)
{
    for(int v = 1; v <= n; ++v)
    {
        if(g[u][v] && !vis[v])
        {
            vis[v] = 1;
            if(linker[v] == -1 || dfs(linker[v]))
            {
                linker[v] = u;
                return true;
            }
        }
    }
    return false;
}

int hungary()
{
    int res = 0;
    memset(linker, -1, sizeof(linker));
    for(int u = 1; u <= p; ++u)
    {
        memset(vis, 0, sizeof(vis));
        if(dfs(u))
            res++;
    }
    return res;
}

int main()
{
    int t, x, v;
    scanf("%d", &t);
    while(t--)
    {
        scanf("%d%d", &p, &n);
        memset(g, 0, sizeof(g));
        for(int i = 1; i <= p; ++i)
        {
            scanf("%d", &x);
            while(x--)
            {
                scanf("%d", &v);
                g[i][v] = 1;
            }
        }
        if(hungary() == p)    ///最大匹配数 = 点数(全部匹配)
            cout<<"YES"<<'\n';
        else
            cout<<"NO"<<'\n';
    }
    return 0;
}

 邻接矩阵,用vector(其实和上面基本一样)

#include <bits/stdc++.h>
using namespace std;
typedef long long ll;
const int inf = 0x3f3f3f3f;
const int mod = 1e9 +7;
const int N = 320;

int uN, vN;
int linker[N];
bool vis[N];
vector<int>g[N];

bool dfs(int u)
{
    int cnt = g[u].size();
    for(int i = 0; i < cnt; ++i)
    {
        int v = g[u][i];
        if(!vis[v])
        {
            vis[v] = 1;
            if(linker[v] == -1 || dfs(linker[v]))
            {
                linker[v] = u;
                return true;
            }
        }
    }
    return false;
}

int hungary()
{
    int res = 0;
    memset(linker, -1, sizeof(linker));
    for(int u = 1; u <= uN; ++u)
    {
        memset(vis, 0, sizeof(vis));
        if(dfs(u))
            res++;
    }
    return res;
}

int main()
{
    int t, x, v;
    scanf("%d", &t);
    while(t--)
    {
        scanf("%d%d", &uN, &vN);
        for(int u = 1; u <= uN; ++u)
        {
            g[u].clear();           //!!!
            scanf("%d", &x);
            while(x--)
            {
                scanf("%d", &v);
                g[u].push_back(v);
            }
        }
        if(hungary() == uN) cout<<"YES"<<'\n';
        else cout<<"NO"<<'\n';
    }
    return 0;
}

邻接表(链式前向星):

#include <bits/stdc++.h>
using namespace std;
typedef long long ll;
const int inf = 0x3f3f3f3f;
const int mod = 1e9 +7;
const int N = 320;

int uN, vN;
int g[N][N];
int linker[N];
bool vis[N];
int head[N], tot;

struct Edge
{
    int to, next;
}edge[100 * N];    //注意边数 >> 点数 (RE警告)

void init()
{
    tot = 0;
    memset(g, 0, sizeof(g));
    memset(head, -1, sizeof(head));
}

void addedge(int u, int v)
{
    edge[tot].to = v;
    edge[tot].next = head[u];
    head[u] = tot++;
}

bool dfs(int u)
{
    for(int i = head[u]; i != -1; i = edge[i].next)
    {
        int v = edge[i].to;
        if(!vis[v])
        {
            vis[v] = 1;
            if(linker[v] == -1 || dfs(linker[v]))
            {
                linker[v] = u;
                return true;
            }
        }
    }
    return false;
}

int hungary()
{
    int res = 0;
    memset(linker, -1, sizeof(linker));
    for(int u = 1; u <= uN; ++u)
    {
        memset(vis, 0, sizeof(vis));
        if(dfs(u))
            res++;
    }
    return res;
}

int main()
{
    int t, x, v;
    scanf("%d", &t);
    while(t--)
    {
        init();
        scanf("%d%d", &uN, &vN);
        for(int u = 1; u <= uN; ++u)
        {
            scanf("%d", &x);
            while(x--)
            {
                scanf("%d", &v);
                addedge(u, v);
            }
        }
        if(hungary() == uN) cout<<"YES"<<'\n';
        else cout<<"NO"<<'\n';
    }
    return 0;
}